1

This question already has an answer here:

I'm new to Ubuntu and really enjoy it. Usually I can find help just by googling cause stuff is so well documented. But I can't figure this problem out when I try to install gparted I get this error. Any ideas?! Any help is appreciated.

The following packages have unmet dependencies:
 gparted : Depends: libglibmm-2.4-1c2a (>= 2.42.0) but 2.39.93-0ubuntu1 is to be installed
           Depends: libparted-fs-resize0 (>= 3.1) but it is not installable
           Depends: libparted2 (>= 3.1) but it is not installable
           Depends: libstdc++6 (>= 4.9) but 4.8.2-19ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

marked as duplicate by A.B., Registered User, Eric Carvalho, RPiAwesomeness, Maythux May 1 '15 at 5:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try sudo apt-get clean && sudo apt-get -f install – Carl H Apr 30 '15 at 12:52
  • Also try dpkg --configure -a to make sure everything has been set up. – TheWanderer Apr 30 '15 at 13:16
  • 1
    those are the dependencies for the vivid version of gparted – mchid Apr 30 '15 at 14:12
6

You are trying to install the wrong version, possibly from a downloaded source. One of the first bad habits you have break coming from windows is downloading software.

I know how it can be to be used to downloading an .exe from where ever and running it to install but Ubuntu has a secure repository containing tens of thousands of apps preconfigured for your specific arch and version (no more downloaded viruses!).

To install gparted (or any software for that matter) you have a few choices.


First, you can do this via the command line line by executing the following two commands:

sudo apt-get update
sudo apt-get install gparted

If you still get the same errors, run the following command:

sudo apt-get install gparted=0.18.0-1

or

sudo apt-get install --reinstall gparted=0.18.0-1

You should have the proper dependencies available for this version (0.18.0-1).

Also, to search for software via the command line you can execute the following commands:

apt-cache search gparted

To narrow the search results, use grep like so:

apt-cache search gparted | grep gparted

Next, use the ubuntu software center:

This method is probably the easiest, just search for software center on your dash, open the app, do a search, and if you see something you want to install, click install.


Finally, use the synaptic package manager:

To install:

sudo apt-get update
sudo apt-get install synaptic policykit-1

Then, to run synaptic, press ALT + F2, type:

synaptic-pkexec

and then press ENTER

Search for and select software. Click on apply to install selected applications.

You can even use synaptic to fix broken packages. Just open synaptic, select "fix broken packages" from the "Edit" menu, and then click "Apply". Note: always review changes before accepting to ensure you do not uninstall something you need to keep.

  • synaptic in a terminal with sudo? -1 – A.B. Apr 30 '15 at 14:05
  • @A.B. I fixed it :) – mchid Apr 30 '15 at 14:29
  • 1
    Now I like your answer +1 – A.B. Apr 30 '15 at 14:32
  • @A.B. good shot, I should've figured out a right way to do that a while ago – mchid Apr 30 '15 at 14:42
  • I especially like synaptic-pkexec – A.B. Apr 30 '15 at 14:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.