3

I tried to install some fonts for my university's corporal design, this failed. Afterwards I removed texlive completely and tried to install it anew (using apt-get), this is not possible since tex-common cannot be configured:

sudo dpkg --configure tex-common

Setting up tex-common (4.04) ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... 
updmap-sys failed. Output has been stored in
/tmp/updmap.tupKRznV
Please include this file if you report a bug.

Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
causes updmap-sys to fail.  Please check for files with extension
.dpkg-dist or .ucf-dist in this directory

dpkg: error processing package tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 tex-common

The directory /etc/texmf/updmap.d does not exist on my system.

The log file mentioned reads:

sudo more /tmp/updmap.tupKRznV

updmap: resetting $HOME value (was /home/XXX) to root's actual home (/root).
updmap is using the following updmap.cfg files (in precedence order):
  /root/.texmf-config/web2c/updmap.cfg
  /usr/share/texmf/web2c/updmap.cfg
  /usr/share/texlive/texmf-dist/web2c/updmap.cfg
updmap is using the following updmap.cfg file for writing changes:
  /etc/texmf/web2c/updmap.cfg
dvips output dir: "/var/lib/texmf/fonts/map/dvips/updmap"
pdftex output dir: "/var/lib/texmf/fonts/map/pdftex/updmap"
dvipdfmx output dir: "/var/lib/texmf/fonts/map/dvipdfmx/updmap"

ERROR:  The following map file(s) couldn't be found:
    dinbold.map (in /root/.texmf-config/web2c/updmap.cfg)
    univers.map (in /root/.texmf-config/web2c/updmap.cfg)

    Did you run mktexlsr?

    You can disable non-existent map entries using the option
      --syncwithtrees.

dinbold and univers are the fonts I tried to install. Actually I don't want them anymore, I just gave up on them. I just want a clean, fresh install of texlive. Soemwhere these fonts are still in system, but I can't find where. What shall I do?

Greetings.

  • With what command you have it removed? – A.B. Apr 30 '15 at 9:47
  • It would be useful to know what has been the procedure you used to try to install the local fonts. Something pesky is going on there... – Rmano Apr 30 '15 at 9:59
1

There is probably something wrong with the procedure you followed to install the local fonts. There are "local user" tex-related files in /root, which is the root user's home directory --- seems like you tried to do a user-local font installation as root, which is a no-no.

Now, even if you un-installed everything with something like apt-get remove --purge, notice that the files in the home directories are never touched by the package system --- even the /root ones.

There should be no tex-related things in /root --- you are not supposed to run TeX &co as root, really. So try to remove those things (everything tex-related under /root) and try again.

  • Thanks, your answer finally led to success. There were two folders in /root/ concerning Tex, I deleted both of them and installed texlive again, now it works. My university's fonts came with a script to install them, I guess this script created those folders. – terri Apr 30 '15 at 11:28
  • @terri, so probably the script is meant to be run as your user, not as root. --- maybe it failed for that. But double check before; if it messes up your local $HOME configuration then it's not easy to go back. – Rmano Apr 30 '15 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.