0

I am new to Ubuntu/Linux, this is my first ever install. Have installed Ubuntu 14.04 on an old HP Probook 5310m & a HP 431. I installed it from USB stick and overwrote Windows 7.

Everything looks good EXCEPT, WiFi doesn't work on either computer. On the Probook, the hard WiFi button on the right of the keyboard is orange (meaning off). Pressing it doesn't help. The system doesn't even seem to see that the pc has a WiFi adapter. On the HP 431, the WiFi is on the F12 key, but no combination of buttons will turn it green (constantly orange).

I've tried running rfkill unblock all in the terminal, but am unsure if I did correctly (how can I tell if I'm "running as root"?). Anyway, didn't help, still no WiFi and orange button.

Also tried the "take battery out, reboot, F10" suggestion above. Didn't help, there was no options in the BIOS setup that seemed to be related to WiFi state.

Interestingly, on the Probook, if I go to "Settings/Network" pressing the WiFi switch seems to turn on and off Airplane mode, but still no WiFi with or without airplane mode being pressed. On the 431 it at least sees there is a WiFi adapter, but under the wireless sign, "WiFi is disabled" is shown but is grey and can't be changed. When I go into settings, it won't let me turn on the WiFi...

Can anyone help? I can supply more information, but you may need to instruct this noob into how to get it.

  • To run a command as root in Ubuntu you run it with help of sudo . In your case: sudo rfkill unblock all. --- Also it could be interesting to know if you installed the original Ubuntu 14.04 or the current 14.04.2 with updated Linux kernel. – pabouk Apr 30 '15 at 8:24
  • This is how you know if you are running as root or not: If you run sudo rfkill unblock all, it will ask for your password and if you type it incorrectly it will say sorry, try again, and if you enter it correctly it will run the command. Another option(not recommended) is running sudo su and entering your password. Then, if you look in the terminal, you can see that you are logged in as root as seen in root@<your-user-name> – Ron Apr 30 '15 at 8:48
  • can you post the results for lspci -vv and look at the Kernal driver in use for your Network controller? – Ron Apr 30 '15 at 9:04
  • If you find, from the above, that your wireless devices have no driver in use, post: lspci -nn | grep 0280. If the result is different in the two laptops, I suggest we pursue one in a new question and the other here. – chili555 Apr 30 '15 at 12:46
0

In case of your probook, you can install the b43 firmware and see if the issue is solve. A detailed description and how-to is here.

In summary, if you can use LAN connection in your probook, follow there instructions (if you are using Ubuntu 12.04 - 14.04). In the terminal type:

sudo apt-get update
sudo apt-get install firmware-b43-installer

Restart your computer.

There is also an option to install this if you can not access internet from your probook. Look at the b43 - No Internet access section of this link.

  • Hey Ron, thanks a lot of this, I followed your instructions and entered the commands above and it worked. Well almost, I get an error if I connect to wifi while plugged in with a network cable (but works fine if I'm not plugged in) and if I hit the hard wifi button on the pc, it turns wifi off and I can only turn on again if I restart, or rather the wifi button is automatically blue and ON when pc is restarted. However, I can live with both of these issues if there's not an easy fix. Again, thanks a lot for your help – Jeff B May 4 '15 at 5:51
  • If you were able to get the wifi working you can accept above post as the answer. Even if you connect both of them at any time you can access internet through only one of them. If you want to connect them at the same time may be this post might help you. – Ron May 4 '15 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.