I can't change themes in my Ubuntu 15.04 after update. It says:

The following schema is missing
org.gnome.settings-daemon.peripherals.touchpad

I've used the dconf editor but touchpad doesn't appear. Mouse and keyboard setting also doesn't open.

  • Are you able to use touchpad, mouse etc..? – Ron Apr 30 '15 at 8:26
  • Same issue for me. Very annoying. – John Jul 19 '15 at 2:51

It's a configuration error in UTT. You need to update some configuration files to use:

org.gnome.desktop.peripherals.touchpad

instead of

org.gnome.settings-daemon.peripherals.touchpad

Just open terminal and type:

sudo -H gedit /usr/lib/python3/site-packages/UnityTweakTool/section/system.py

Then change the following lines so they look like:

  • Line 182: 'schema' : 'org.gnome.desktop.peripherals.touchpad',
  • Line 193: 'schema' : 'org.gnome.desktop.peripherals.touchpad',
  • Line 205: 'schema' : 'org.gnome.desktop.peripherals.touchpad',

Save changes, close gedit and, again in terminal:

sudo -H gedit /usr/lib/python3/site-packages/UnityTweakTool/section/spaghetti/gsettings.py

Change the following line to:

  • Line 114 (in 15.10 its line 120): touch = gnome('desktop.peripherals.touchpad')

Save and exit. UnityTweakTool should now start without problems.

Note:

If you can't find /usr/lib/python3/site-packages/, then you should have /usr/lib/python3/dist-packages/ instead.

  • Works for me on Ubuntu 15.10, thank you. – Le Gluon du Net Aug 26 '15 at 14:19
  • Perfect . Thanks it works. – Rajat Pandita Sep 16 '15 at 5:58
  • For 15.10, has someone filed it as bug? I will if not. – eudoxos Sep 16 '15 at 10:02
  • This worked for me as well, thanks. – chest069 Sep 25 '15 at 14:36
  • Thanks! This worked under Ubuntu 15.10 as well. Alternatively, one can enter these two command in a terminal window: sudo sed -i "s/org\.gnome\.settings\-daemon\.peripherals\.touchpad/org\.gnome\.desktop\.peripherals\.touchpad/g" "/usr/lib/python3/dist-packages/UnityTweakTool/section/system.py" and sudo sed -i "s/org\.gnome\.settings\-daemon\.peripherals\.touchpad/org\.gnome\.desktop\.peripherals\.touchpad/g" "/usr/lib/python3/dist-packages/UnityTweakTool/section/spaghetti/gsettings.py" – Sadi Oct 25 '15 at 12:22

The missing schemas are provided by the gnome-settings-daemon-schemas package.

Try to reinstall it with (in a terminal):

sudo apt-get install --reinstall gnome-settings-daemon-schemas

The schemas should now be installed in:

/usr/share/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.gschema.xml
  • 2
    For me, this did not work. Still the same error and the mouse and kb settings still don't open. – fnl Jun 10 '15 at 12:15
  • 1
    I reinstalled as above with no fix. Reading the schema in gedit, I found 'org.gnome.settings-daemon.peripherals.touchpad.deprecated' but not the missing schema itself (no '.deprecated'). Any ideas what's going on here? – beachbuddah Jun 10 '15 at 22:53
  • This issue still exists in Xenial. This solution (minor change - install, not reinstall) fixed it. – Haqa Oct 12 '17 at 12:04

protected by Community Aug 30 '15 at 6:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.