How do you tether a bq Ubuntu phone to a laptop by usb or bluetooth? -- [is there an application?]

Does not seem to have an app for it, but can be done:

  • Connect your device via USB, enable Developer Mode in: "System-Settings->About This Phone->Developer Mode"
  • Run (from your PC, making sure to have the phone screen unlocked, else adb will refuse to let you in):
    adb shell android-gadget-service enable rndis
    This will enable tethering. It will also disable MTP (USB file access). You can re-enable MTP later with:
    adb shell android-gadget-service enable mtp

If the adb command above fails, it might be because the vendor of the phone is unkown (it was for me in 14.04). In that case find it with

lsusb Bus 001 Device 010: ID 2a47:0c02

And add it to ~/.android/adb_usb.ini
0x2a47

Then restart the adb server after you edited the file with:

sudo adb kill-server; sudo adb start-server


Note that the above answer is not required any more. In the device "System Settings" there is now a "Hotspot" section to achieve it painlessly.

Now there is an app. But you have to install the Open Store as described here.

  • In summary you just have to run the following two lines in the phone terminal (taken from the comments from Zachary Igielman):

wget http://notyetthere.org/openstore/v1/openstore.mzanetti_0.2_armhf.click

pkcon install-local --allow-untrusted openstore.mzanetti_0.2_armhf.click

  • Then open up the Open Store via the now installed app with the same name and update it.
  • Then install TweakGeek (no password request) or Ubuntu Touch Tweak Tool (password request). Ubuntu Desktop automagically connects to the Internet via the BQ once you plug in the USB cable (after selecting USB tethering from TweakGeek).
  • TweakGeek works fine, but when i installed TweakGeek, the phone (Aquaris E5 Ubuntu Edition) will not identified as mtp:/ on the desk. Uninstall TweakGeek solves this problem. What can i do? Thanks. (Sorry for my bad english) – user474380 Nov 20 '15 at 23:18

protected by RolandiXor Nov 21 '15 at 17:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.