1

I am trying to use the ethernet port on my Lenovo y580, which previously worked untill I upgraded to ubuntu 15.04 from 14.10. My hardware is recognized, and I can connect to an ethernet network, however whenever I try to load a webpage the connection just stops working. I can observe this by pinging my router while connected via ethernet. Whenever I try to load the page, the ping command just freezes. This has been an issue ever since I upgraded to 15.04 Beta.

I believe this is an error with the alx driver based off of my research. My wireless card is a Qualcomm Atheros AR8161. Does anyone know a workaround, or have a verification of my issue?

EDIT: I tried this, as recommended by one user, and it did not sucessfully compile. I believe that the user here was having a different issue, as he did not specify my issue.

4

https://bugzilla.kernel.org/show_bug.cgi?id=70761 this gives the work around

In the networking indicator select Edit Connections
On wired connection 1 change the MTU to 8192
Save this

Reboot working wired connection

| improve this answer | |
  • Amazing - this worked perfectly. – Bachi Jun 20 '15 at 17:21
0

Same here... worked perfectly in 14.04 then there were issues in 14.10 with virtual machines causing eth0 to stop working now in 15.04 eth0 only works for a few seconds then stops. if I restart

$ sudo service network-manager restart
then the network comes back up for only a few seconds then stops again.
The driver is "alx"

$ lshw
  *-network               
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 08
       serial: b8:88:e3:8a:4b:01
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
       resources: irq:31 memory:d3600000-d363ffff ioport:2000(size=128)


$ modinfo alx
filename:       /lib/modules/3.19.0-15-generic/kernel/drivers/net/ethernet/atheros/alx/alx.ko
license:        GPL
description:    Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
author:         Qualcomm Corporation, <nic-devel@qualcomm.com>
author:         Johannes Berg <johannes@sipsolutions.net>
srcversion:     1917D292620190CB7319BDE
alias:          pci:v00001969d000010A0sv*sd*bc*sc*i*
alias:          pci:v00001969d000010A1sv*sd*bc*sc*i*
alias:          pci:v00001969d00001090sv*sd*bc*sc*i*
alias:          pci:v00001969d0000E091sv*sd*bc*sc*i*
alias:          pci:v00001969d00001091sv*sd*bc*sc*i*
depends:        mdio
intree:         Y
vermagic:       3.19.0-15-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        9E:64:80:70:92:F3:A6:A8:F6:6F:3B:7E:A4:CB:37:67:FD:FA:E0:8A
sig_hashalgo:   sha512

The Driver hasn’t been worked on in some time https://github.com/mcgrof/alx

| improve this answer | |
  • Is there a bug report filed on launchpad, or can we file one? I do not know how to go about this process. – NStephenH May 1 '15 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.