1

I upgraded from Ubuntu 14.10 to 15.04 this past weekend, and everything installed perfectly, with the exception of texlive-pstricks-doc. It gave me an error when the upgrade finished.

Since then, I've tried to manually update the package, and this is my output from the terminal.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  texlive-pstricks-doc
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/85.6 MB of archives.
After this operation, 9,585 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 275255 files and directories currently installed.)
Preparing to unpack .../texlive-pstricks-doc_2014.20141024-1_all.deb ...
Unpacking texlive-pstricks-doc (2014.20141024-1) over (2014.20140717-1) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/texlive-pstricks-doc_2014.20141024-1_all.deb (--unpack):
 cannot copy extracted data for './usr/share/doc/texlive-doc/generic/pstricks-add/pstricks-add-doc.dat.gz' to '/usr/share/doc/texlive-doc/generic/pstricks-add/pstricks-add-doc.dat.gz.dpkg-new': unexpected end of file or stream
Processing triggers for tex-common (5.03) ...
Running mktexlsr. This may take some time... done.
Errors were encountered while processing:
 /var/cache/apt/archives/texlive-pstricks-doc_2014.20141024-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • File a bug. This is something that needs fixed at the developer level, not here on Ask Ubuntu. – Thomas Ward Apr 30 '15 at 2:44
  • Okay. Thanks for the answer. I thought it might be something related to my set up, which is why I asked here. I'll file it. – Andrew Wallace Apr 30 '15 at 3:29
0

Alright, after checking a couple of things, I ran sudo apt-get clean, then ran the update again. This time, it downloaded a new copy of texlive-pstricks-doc, and installed it without issue. Turns out, it was just a broken download.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.