0

I have a GTX670 graphics card and a Philips BDM4065UC monitor which is configured for displayport 1.2.

When I run Ubuntu 14.04.2 (amd64) from a USB boot mode using the tryme mode, my screen comes up as 3840x2160@60hz, so I know the card/monitor/driver configuration works.

When I run the install everything is fine, but after I reboot I only get 3840x2160@30hz. I've tried using xrand, and as far as the system is concerned, 60hz is not supported.

To fix this, I figured the easiest way would be to copy the appropriate config files from the tryme setup into my permanent setup (I can easily reproduce this by booting from USB).

Has someone come across this before, and can tell me how to fix my configuration to get 60hz?

here is my monitors.xml file

no VSC 0xf62b 0x01010101 1920 1080 60 0 0 normal no no yes PHL 0x08e1 0x000016ec 3840 2160 60 1920 0 normal no no no

  • Welcome to Ask Ubuntu ;-) Could you edit your question and add the following information: nVidia module version and the contents of your monitor.xml. If you don't know how to do this, please leave a comment below! :-) – Fabby Apr 30 '15 at 17:57
  • Please also post the requested information if you want to get to the bottom of this, because your solution is just a workaround... (staying away from nvidia drivers) ;-) :P – Fabby May 3 '15 at 12:31
  • sorry, I don't know how to find the nVidia module version, and the formatting of the monitors.xml file doesn't display properly – Greg Smart May 4 '15 at 12:06
  • nvidia-settings --version and post monitors.xml to paste.ubuntu.com and provide the link back. – Fabby May 4 '15 at 13:35
0

Try sudo apt-get install nvidia-current As that will install nvidia drivers.

0

I have tried several re-installs since posting the original question and I have been able to get my system running with 3840x2160@60hz. This post is to help others who might have the same problem.

One of the things that concerned me about my setup is that I can't make the displayport output the primary monitor on the system if the DVI ports are used. The GTX670 had 1xDP, 1xHDMI and 2xDVI ports. I disconnected all other monitors except the BDM4065UC and reinstalled as normal (I have a dual-boot with win7, so I run boot-repair to fix grub after install). This worked without a problem. I then ran "sudo apt-get install nvidia-current" which caused me to lose my 60hz config, and I when back to only 30hz being supported. I then tried re-installing again, this time with my other monitor connected (a Viewsonic 27", which runs 1920x1080@60hz). The Viewsonic became the primary monitor, but the install still worked, and the BDM4065UC is running at 3840x2160@60hz. I haven't been able to work out why the install didn't work previously, but I am keeping away from the nvidia driver at the moment. I expect it doesn't support my monitor. thanks to those who tried to help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.