1

Very very wide system sound settings window.

In the picture you can see that the sound settings window is absurdly wide. There is one sound output device that plays to all connected devices, and it's name is very long, as it lists all of the devices. This being so long has pushed the borders of my window past the edges of the screen, and now spans multiple desktops.

Being able to do any of the following should fix my problem.

A. Force the window dimensions to remain within the screen.
B. Wrap the long line.
C. Give the device a custom shorter name.
D. Make the window resizeable, with the device list horizontally-scrollable.

  • I think this is clearly a bug in gnome-control-center. You can report it on launchpad... – Rmano Apr 30 '15 at 8:18
2

Unfortunately the window size of the GNOME sound settings is hard-coded and can not be changed. It will adapt its size according to the length of display for a chosen audio sink.

To overcome this we can use a custom name (device.description) for the rather lengthy combined sink to not list all slaves we had used.

Rather than by running paprefs we create this custom named combined sink by loading module-combine-sink (or module-combine in pulseaudio < 1.0) from a terminal (or from our default.pa in case we always need such a combined sink) with the following parameters:

pactl load-module module-combine-sink sink_properties=device.description=Combined

After that the combined sink name will nicely fit into the sound settings window:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.