My wifi connection has gone unstable and I suspect it has something to do with upgrading to 15.04.

I am working on a Lenovo Yoga 2 (not pro) laptop. The wireless card is Intel 7260, the driver is iwlwifi.

In case that is useful, here is additional info:

>>    cat /etc/lsb-release 

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu 15.04"

>>    lsusb 

Bus 003 Device 002: ID 8087:8000 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 048d:8350 Integrated Technology Express, Inc. 
Bus 001 Device 005: ID 8087:07dc Intel Corp. 
Bus 001 Device 004: ID 04f2:b40f Chicony Electronics Co., Ltd 
Bus 001 Device 003: ID 04f3:0303 Elan Microelectronics Corp. 
Bus 001 Device 002: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

>>    lspci -k -nn | grep -A 3 -i net 

01:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 6b)
    Subsystem: Intel Corporation Wireless-N 7260 [8086:c262]
    Kernel driver in use: iwlwifi

>>    sudo lshw -C network 

  *-network
       description: Interface réseau sans fil
       produit: Wireless 7260
       fabriquant: Intel Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: wlan0
       version: 6b
       numéro de série: e8:b1:fc:0c:54:b3
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.19.0-15-generic firmware=25.15.12.0 ip=192.168.25.76 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       ressources: irq:45 mémoire:b0400000-b0401fff

>>    lsmod 

Module                  Size  Used by
ctr                    16384  1 
ccm                    20480  1 
binfmt_misc            20480  1 
rfcomm                 69632  8 
bnep                   20480  2 
rtsx_usb_ms            20480  0 
memstick               20480  1 rtsx_usb_ms
hid_sensor_magn_3d     16384  0 
hid_sensor_incl_3d     16384  0 
hid_sensor_rotation    16384  0 
hid_sensor_accel_3d    16384  0 
hid_sensor_gyro_3d     16384  0 
hid_sensor_als         16384  0 
hid_sensor_trigger     16384  12 hid_sensor_gyro_3d,hid_sensor_incl_3d,hid_sensor_accel_3d,hid_sensor_rotation,hid_sensor_als,hid_sensor_magn_3d
industrialio_triggered_buffer    16384  6 hid_sensor_gyro_3d,hid_sensor_incl_3d,hid_sensor_accel_3d,hid_sensor_rotation,hid_sensor_als,hid_sensor_magn_3d
kfifo_buf              16384  1 industrialio_triggered_buffer
industrialio           57344  9 hid_sensor_trigger,hid_sensor_gyro_3d,industrialio_triggered_buffer,hid_sensor_incl_3d,hid_sensor_accel_3d,hid_sensor_rotation,hid_sensor_als,kfifo_buf,hid_sensor_magn_3d
hid_sensor_iio_common    16384  6 hid_sensor_gyro_3d,hid_sensor_incl_3d,hid_sensor_accel_3d,hid_sensor_rotation,hid_sensor_als,hid_sensor_magn_3d
hid_multitouch         20480  0 
hid_sensor_hub         20480  8 hid_sensor_trigger,hid_sensor_gyro_3d,hid_sensor_incl_3d,hid_sensor_accel_3d,hid_sensor_rotation,hid_sensor_als,hid_sensor_magn_3d,hid_sensor_iio_common
uvcvideo               90112  0 
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_core         49152  1 uvcvideo
v4l2_common            16384  1 videobuf2_core
videodev              159744  3 uvcvideo,v4l2_common,videobuf2_core
usbhid                 53248  0 
media                  24576  2 uvcvideo,videodev
btusb                  32768  0 
bluetooth             491520  22 bnep,btusb,rfcomm
arc4                   16384  2 
snd_hda_codec_hdmi     53248  1 
joydev                 20480  0 
intel_rapl             20480  0 
iosf_mbi               16384  1 intel_rapl
x86_pkg_temp_thermal    16384  0 
intel_powerclamp       20480  0 
coretemp               16384  0 
kvm                   483328  0 
iwlmvm                278528  0 
mac80211              720896  1 iwlmvm
crct10dif_pclmul       16384  0 
crc32_pclmul           16384  0 
ghash_clmulni_intel    16384  0 
snd_hda_codec_realtek    86016  1 
aesni_intel           172032  3 
snd_hda_codec_generic    69632  1 snd_hda_codec_realtek
iwlwifi               196608  1 iwlmvm
aes_x86_64             20480  1 aesni_intel
lrw                    16384  1 aesni_intel
i915                 1052672  7 
gf128mul               16384  1 lrw
cfg80211              540672  3 iwlwifi,mac80211,iwlmvm
glue_helper            16384  1 aesni_intel
ablk_helper            16384  1 aesni_intel
cryptd                 20480  3 ghash_clmulni_intel,aesni_intel,ablk_helper
snd_soc_rt5640         94208  0 
snd_soc_rl6231         16384  1 snd_soc_rt5640
snd_hda_intel          32768  7 
snd_hda_controller     32768  1 snd_hda_intel
shpchp                 40960  0 
snd_hda_codec         143360  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_soc_core          196608  1 snd_soc_rt5640
snd_compress           20480  1 snd_soc_core
mei_me                 20480  0 
snd_hwdep              20480  1 snd_hda_codec
snd_pcm_dmaengine      16384  1 snd_soc_core
serio_raw              16384  0 
mei                    90112  1 mei_me
snd_pcm               106496  8 snd_soc_rt5640,snd_soc_core,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller,snd_pcm_dmaengine
snd_seq_midi           16384  0 
lpc_ich                24576  0 
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
drm_kms_helper        122880  1 i915
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
drm                   344064  6 i915,drm_kms_helper
snd_timer              32768  2 snd_pcm,snd_seq
i2c_algo_bit           16384  1 i915
snd                    90112  26 snd_hda_codec_realtek,snd_soc_core,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_compress
ideapad_laptop         20480  0 
soundcore              16384  2 snd,snd_hda_codec
sparse_keymap          16384  1 ideapad_laptop
i2c_hid                20480  0 
hid                   110592  4 i2c_hid,hid_multitouch,hid_sensor_hub,usbhid
video                  20480  1 i915
dw_dmac                16384  0 
dw_dmac_core           24576  1 dw_dmac
snd_soc_sst_acpi       16384  0 
8250_dw                16384  0 
i2c_designware_platform    16384  0 
spi_pxa2xx_platform    24576  0 
i2c_designware_core    16384  1 i2c_designware_platform
soc_button_array       16384  0 
mac_hid                16384  0 
parport_pc             32768  0 
ppdev                  20480  0 
lp                     20480  0 
parport                45056  3 lp,ppdev,parport_pc
autofs4                40960  2 
rtsx_usb_sdmmc         28672  0 
rtsx_usb               24576  2 rtsx_usb_sdmmc,rtsx_usb_ms
psmouse               118784  0 
ahci                   36864  1 
libahci                32768  1 ahci
sdhci_acpi             16384  0 
sdhci                  45056  1 sdhci_acpi
[/code]
[code]

>>    iwconfig 

wlan0     IEEE 802.11bgn  ESSID:"GVT-947C"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0C:C3:3B:94:7C   
          Bit Rate=1 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=45/70  Signal level=-65 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:13  Invalid misc:87   Missed beacon:0


>>    ifconfig -a 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:6898 erreurs:0 :0 overruns:0 frame:0
          TX packets:6898 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:626740 (626.7 KB) Octets transmis:626740 (626.7 KB)

wlan0     Link encap:Ethernet  HWaddr e8:b1:fc:0c:54:b3  
          inet adr:192.168.25.76  Bcast:192.168.25.255  Masque:255.255.255.0
          adr inet6: fe80::eab1:fcff:fe0c:54b3/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:200288 erreurs:0 :0 overruns:0 frame:0
          TX packets:139328 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:207651439 (207.6 MB) Octets transmis:19177032 (19.1 MB)


>>    sudo iwlist scan 

wlan0     Scan completed :
          Cell 01 - Address: 00:0C:C3:3B:94:7C
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=48/70  Signal level=-62 dBm  
                    Encryption key:on
                    ESSID:"GVT-947C"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000de3b507a8
                    Extra: Last beacon: 26572ms ago
                    IE: Unknown: 00084756542D39343743
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010B
                    IE: Unknown: 0706425220010D14
                    IE: Unknown: 2A0106
                    IE: Unknown: 2F0106
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 0B0508007A0000
                    IE: Unknown: 2D1ABC1817FFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B001700000000000000000000000000000000000000
                    IE: Unknown: 7F03000008
                    IE: Unknown: DD800050F204104A0001101044000102103B000103104700107A100A47716E8627B12CA6C7656292D41021000842726F6164636F6D1023000842726F6164636F6D1024000631323334353610420004313233341054000800060050F20400011011000A42726F6164636F6D415010080002200C103C0001011049000600372A000120
                    IE: Unknown: DD090010180208040C0000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00


>>    uname -r -m 

3.19.0-15-generic x86_64

>>    cat /etc/network/interfaces 

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

>>    nm-tool 


>>    sudo rfkill list 

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

And as requested by spinxz in the comments below:

>>    modinfo iwlwifi | grep 7260

firmware:       iwlwifi-7260-10.ucode

>>    dmesg | grep iwl

[    2.303627] iwlwifi 0000:01:00.0: loaded firmware version 25.15.12.0 op_modeiwlmvm
[    2.333529] iwlwifi 0000:01:00.0: Detected Intel(R) Wireless N 7260, REV=0x144
[    2.333581] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[    2.333802] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[    2.555400] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    4.830019] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[    4.830243] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[   66.550674] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[   66.550900] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled

Another request (by gertvdijk in the comments below):

>>    apt-cache policy linux-firmware

linux-firmware:
  Installé : 1.143
  Candidat : 1.143
 Table de version :
 *** 1.143 0
        500 http://fr.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

To answer another question of sinxz, here is the output of dmesg | grep iwl after a disconnect and reconnect:

[    2.303627] iwlwifi 0000:01:00.0: loaded firmware version 25.15.12.0 op_mode iwlmvm
[    2.333529] iwlwifi 0000:01:00.0: Detected Intel(R) Wireless N 7260, REV=0x144
[    2.333581] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[    2.333802] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[    2.555400] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    4.830019] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[    4.830243] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[   66.550674] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[   66.550900] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[ 2212.567922] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled
[ 2212.568146] iwlwifi 0000:01:00.0: L1 Disabled - LTR Enabled

Edit: I also posted this question on the official French Ubuntu forum (here), and a user there made remarks that raise two questions:

  1. Is it possible that power management was always off on my previous version of Ubuntu (14.10)?
  2. Is it normal that there is a file iwlwifi.conf in /etc/modprobe.d with the following content?

    # /etc/modprobe.d/iwlwifi.conf
    # iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
    # microcode file installed on the system. When removing iwlwifi, first
    # remove the iwl?vm module and then iwlwifi.
    remove iwlwifi \
    (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs/sbin/rmmod) \
    && /sbin/modprobe -r mac80211

Edit 2: It seems that my problem could now be completely solved. Let me make a few clarifications: the "instability" of my connection can be summed up by two "symptoms":

  1. Slow rates (concretely, max download speed at around 150Kb/s instead of 1Mb/s when it worked properly)
  2. "Effective disconnection" very frequently (every 30 seconds, say). What I mean by that is that the connection is not working at all, but the wifi does not "officially" disconnect. It comes back after waiting a few seconds (10 to 20s, say) or reconnecting to the network.

At first I thought that doing sudo iwconfig wlan0 power off solved these issues completely, even if turning off power management is apparently not a "sustainable" solution (see spinxz's comments below). However I then realized that symptom #2 is still there, although much less frequently.

On the French Ubuntu forum (here), someone suggested I try to manually put the latest version of the version 12 firmware (downloadable here: https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-7260-ucode-25.17.12.0.tgz) in /lib/firmware. I did that, and now the problem seems to be solved completely. To be honest, it might also have something to do with recent Ubuntu updates (they were a lot recently), I don't know. I am still not 100% certain the connection is back to working perfectly, or if it is only as good as the "power management off" solution, for example. I will let you know if that is the case.

  • Hi, I can confirm the same problem. I suspect that this might be because that the wrong firmware is loaded. What is your output to modinfo iwlwifi | grep 7260. In my case the version 10 of the firmware is loaded. However, according to [wireless.wiki.kernel.org/en/users/drivers/iwlwifi ] a 3.19 kernel needs the version 12. In /lib/firmware under ubuntu 15.04 I can see this version but it is not loaded. In my case turning off powermgt helped a bit: sudo iwconfig wlan0 power off – spinxz May 1 '15 at 12:25
  • Please also show the output of dmesg | grep iwl. Do you see a microcode error? – spinxz May 1 '15 at 12:32
  • Hi, thanks for your attention. Please see edited question with the requested outputs. (it seems I am in the same situation as you) – Seub May 1 '15 at 13:49
  • So, maybe we can simply "install" the version 12 of the firmware by doing # cp iwlwifi-*.ucode /lib/firmware (with the right file), as your link suggests, no? – Seub May 1 '15 at 13:53
  • Ubuntu Vivid repositories install the -12 firmware. See the changelog of the linux-firmware package:iwlwifi: add new -12 firmware for 3160 / 7260 / 7265 / 7265D . Are you sure you have installed that package correctly? Or did you make changes to your system before the upgrade? Please elaborate more. And include the output of apt-cache policy linux-firmware. I'm using the exact same card with 15.04 clean install and it is rock solid. – gertvdijk May 1 '15 at 14:02

I have similar problems with my Intel 7260 wifi and did some research on how to fix these issues.

It turns out that lots of people have problems with this wifi card and its related driver the iwlwifi. However, it seems there is no easy apply and forget fix as people are reporting different problems (also due to different APs being used of course). Hence, some testing is has to be done.

The following links should be helpful:

I found several related bug reports on launchpad, see here, here, here, and here.

Furthermore, on the Archwiki there is a useful troubleshooting section for the iwlwifi driver.

Last but not least here is also a brief summary on how to fix iwlwifi related problems.

Some suggested solutions are:

  • Turn off bluetooth (use rfkill or turn off in Bios)
  • Turn OFF 802.11n mode (in /etc/modprobe.d/iwlwifi.conf add options iwlwifi 11n_disable=1)
  • Turn ON link aggregation (in /etc/modprobe.d/iwlwifi.conf add options iwlwifi 11n_disable=8)
  • Turn OFF watchdog (in /etc/modprobe.d/iwlwifi.conf add options iwlwifi wd_disable=1)
  • Turn off power saving features ($ sudo iw wlan0 set power_save off)
  • Set regulatory domain ($ sudo iw reg set <country code>)

In my case the stability problems were coming from frequent disconnects showing up in the syslog (-> dmesg) as follows:

wlan0: deauthenticating from ....... by local choice (Reason: 3=DEAUTH_LEAVING)

I am running Ubuntu 15.04 (x64) with a 3.19 Linux kernel.

In my case it seems that the problems are fixed just by turning on link aggregation (11n_disable=8). Turning off power saving also seems to help. This holds for the 2.4GHz network.

For the 5GHz network I could not solve the problems and the link is highly unstable.


For how to turn off wifi power management permanently see here and here.

  • I had the same problem on clean install of Ubuntu 14.04 and these steps fixed the wireless problems I was experiencing. – jbird Jan 14 '16 at 17:53
  • worked on 15.10 too. – Exeleration-G Feb 25 '16 at 23:25

Before you go messing with your kernel as lpbug suggested, I think you should try tinkering with other things that don't have such a high risk of breaking things.

The fact that your device seems to be loading data slowly leads me to believe that the problem might be an issue between your router and your computer. Have you tested the data rate in another network while comparing to another device as a benchmark (your phone)? That might help us narrow down what is wrong.

Have you tried turning off 802.11n in your /etc/modprobe.d/iwlwifi.conf? I have the same wireless card and turning this off greatly improved my network's performance.

To turn it off, add the following line to /etc/modprobe.d/iwlwifi.conf:

options iwlwifi 11n_disable=1

Now restart the module:

sudo modprobe -r iwlmvm
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

Note for other readers with a similar problem to OP: you might have to replace iwlmvm above with iwldvm, depending on your system.

Let me know if that helps at all.

By the way, to address your second question from your edit, yes, the iwlwifi config file should have the exact lines you listed.

  • Thank you very much for trying to help. This sounds like a good suggestion. However it seems that my connection is now restored (to be confirmed, see edited question soon). But I am still not 100% certain, and as soon as I experience problems again (if I do) I will try your idea to see if it makes any change. – Seub May 8 '15 at 11:12

First of all, I should preface this with the fact that my network card is the Dual band version of the Intel Wireless N 7260 REV=0x144. but according to the 3rd post of this thread, it seems like out hardware is the same. I've had this unstable wifi problem for close to a year now and it seems like other with this card have had the same issue. This persisted until I recently tried different kernels.

The symptom for the unstable wifi would include (in order of most common occurence): Not being able to connect to wifi network upon returning from suspsend unless the computer has been restarted, or iwlwifi restarted; taking a really, really long time to connect to a network (on the order of a minute); being disconnected randomly from the wifi network I am on.

I dual boot windows 7 with this and the same piece of hardware performs very well. This lead me to believe that this is more of a software problem. I tried out the 3.17.0 rc2 mainline kernel and my unstable wifi problem disappeared, now it only takes me about 10 seconds to connect to a wifi network and connections are rock solid. To my knowledge, the 3.17 kernels use firmware:iwlwifi-7260-9.ucode so if you can just try that version of iwlwifi it may work better.

HOWEVER...

You should read this post before considering to do the same thing as I had. Before, I was getting 120 mbps up and down easily when I had a good wifi connection. Now, I only get 20 mbps up and down (tested this in windows 7 as control, and it seems like it is also getting 120+ mbps as before). I am unsure if this is a result of the kernel switch. In my case, it is a tradeoff between speed and stability and I would take 20 mbps of stable wifi over 120 mbps of unstable wifi.

If you decide to proceed: the steps I took for installing the new kernel:

cd /tmp

then

wget the following from the 3.17.0 rc2 mainline page:

linux-headers-3.17.0-031700rc2-lowlatency_3.17.0-031700rc2.201408251935_amd64.deb

linux-headers-3.17.0-031700rc2_3.17.0-031700rc2.201408251935_all.deb

linux-image-3.17.0-031700rc2-lowlatency_3.17.0-031700rc2.201408251935_amd64.deb

finally, sudo dpkg -i linux-headers-3.17.0-*.deb linux-image-3.17.0-*.deb

then reboot and check that the firmware loaded is version 9.

I really hope this works for you.

  • Hi and thank you very much for trying to help. However we appear to be experiencing different problems: I have none of your symptoms; my symptoms are just low rates and "disconnection in effect" (zero connection although the network does not show disconnection) all the time (every 30 seconds, say). Also, it looks like my problem could actually be solved now (see question edit soon). For these reasons I am relunctant to try to change the kernel or downgrade the firmware version. But again, thanks for this answer. – Seub May 8 '15 at 11:00

I couldn't fix this problem so wrote the following script to restart my card when it went down. Just put it in /etc/init.d/ and make it executable. It's not ideal but I barely notice the problem anymore.

#!/bin/bash

while sleep 1
do
    wget -q --tries=10 --timeout=20 --spider http://google.com
    if [[ $? -eq 0 ]]; then
        echo "Online"
    else
    echo "Offline - restarting"
    rfkill block wifi
    sleep 1
    rfkill unblock wifi
    sleep 1
    ifconfig wlan0 down
    sleep 1
    ifconfig wlan0 up
    sleep 10
    fi
done

These commands were helpfull to me on linux lite 3.2

Have you tried turning off 802.11n in your /etc/modprobe.d/iwlwifi.conf? I have the same wireless card and turning this off greatly improved my network's performance.

" To turn it off, add the following line to /etc/modprobe.d/iwlwifi.conf:

options iwlwifi 11n_disable=1

Now restart the module:

sudo modprobe -r iwlmvm sudo modprobe -r iwlwifi sudo modprobe iwlwifi "

Thank you

In my case the only solution that worked was to "disable 11n functionality", but this:

options iwlwifi 11n_disable=2

Also gives stability and speed is a little better. It supposedly only disables "agg TX":

modinfo iwlwifi | grep 11n_disable
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.