0

I have recently installed ubuntu 15.04 for my macbook pro retina and if I go to the terminal and type "top" I see that there is always a ~10% usage by "sy". The command which is causing this much usage is kworker (I dont know what this is). I think this is not normal since my macbook also becomes warmer. On ubuntu 14 I did not have this problem. Is it already known why this happens or do I have to wait until this bug is fixed?

0

I can't take credit for this but this tutorial has an answer:http://teslabs.com/articles/ubuntu-15-04-mbp-11-2/#comment-2020153043

High CPU usage by kworker The most important issue I have found so far is the high CPU usage by kworker (i.e. Linux Kernel worker thread), which seriously affects the battery life. Apparently this is caused by an interrupt storm on ACPI interrupt GPE06, as described here. You can verify it by checking if interrupt GPE06 contains a high value:

$ grep . -r /sys/firmware/acpi/interrupts/

...

/sys/firmware/acpi/interrupts/gpe05:       0   invalid
/sys/firmware/acpi/interrupts/gpe06: 2938373   enabled <---
/sys/firmware/acpi/interrupts/gpe07:       0   enabled

... A quick solution for this issue is to disable this interrupt, i.e.

echo disable > /sys/firmware/acpi/interrupts/gpe06

In order to disable it on every boot, you can add the previous line to /etc/rc.local, just before exit 0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.