7

Since a few days and the upgrade of my Ubuntu from 14.10 to 15.04, I cannot send files to trash anymore from some folders.

When deleting from Nautilus, I now get a popup saying:

“aaa.png” can't be put in the trash. Do you want to delete it immediately?

That worked perfectly for years :(

I have a dual boot system Ubuntu/Windows. Ubuntu is on EXT4 partitions while Windows and data are on NTFS ones.

The NTFS partitions are mounted via gvfs at login:

gvfs-mount -d /dev/sdb9

In my home folder, I have several symbolic links to folders on the NTFS partitions, like this one:

Downloads -> /media/stephane/dmn/User/Downloads/

I tried from terminal in ~/Downloads:

gvfs-trash aaa.png
Error trashing file: Unable to trash file: Invalid cross-device link

But in the original folder /media/stephane/dmn/User/Downloads/, the same command works perfectly !

While I kind of understand the error, that setup has been in place for years and I have been trashing files without looking back and without problems either.

So what happened to gvfs-trash and why isn't it suddenly able to trash such files anymore?

Is there a way to make it work again?

Things I have tried:

  • check the permissions of ~/.local/share/Trash: it's all mine as well as its subfolders
  • check the permissions of .Trash-1000/ on the NTFS partitions: same thing, I have all the right permissions
  • mount NTFS via fstab instead of gvfs-mount: not a thing changed
2
  • I have the same problem, thank you for precisely describing it and for suggesting a workaround (i.e., go to the original folder rather than symlink). I found this bug report: bugzilla.gnome.org/show_bug.cgi?id=748629 – Steve Byrnes May 5 '15 at 19:19
  • On USB-disks we get a trash-folder during creation, named .Trash-1000 (.trash-GID) the group Id. Where all files and folders deleted (without shift) ends up, and is automatically linked to the Trash Icon in file-managers or desktop, so there must be a similar neat solution somewhere out there!! Please someone Help us :-( – Ken Mollerup Dec 7 '16 at 9:33
1

I have not found any real solution for this but i do have a work around that is slightly less annoying that browsing to the downloads folder on the other partition.. i created a softlink to the Downloads folder in the downloads folder... I know this sounds weird but it does not throw up the error when you go to the 2nd downloads folder and delete something.

So basically this happens: browse to ~/Downloads (which itself is a softlink to the other partition) click on the "Downloads" softlink in that folder (which basically links to itself) now you can delete files without the annoying error. its one extra click but saves browsing the other partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.