2

I have just installed Ubuntu 14.04 on my machine. My kernel version is:

3.16.0-34-generic

My problem is that download speed in Ubuntu (measured via speedtest.net) is 0.78 Mbps while on Windows (installed on the same machine) I have 21,84 Mbps. What can be important is that I also had a problem with constantly disconnecting Wi-Fi, which I resolved by forcing AES encryption in my Wi-Fi router. My Wi-Fi adapter is

D-Link DWA-121 Wireless N 150 Pico USB Adapter

and the relevant part of output of iwconfig is:

wlan0     IEEE 802.11bgn  ESSID:"UPC1307036"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 64:7C:34:3D:ED:CE   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:134   Missed beacon:0

I tried the solutions from other questions of this kind, but they didn't work, so I'm starting a new question.

1
  • I hope my question is worded properly. Please let me know if it lacks some important informations. – Marek Lipka Apr 29 '15 at 19:47
4

Compile and install the proprietary Realtek 8192cu driver. To do this, run the following commands in an open terminal:

sudo apt-get update && sudo apt-get install git build-essential linux-headers-generic dkms
git clone https://github.com/dz0ny/rt8192cu.git --depth 1
cd rt8192cu
sudo make dkms

For hard installation use:

make
sudo make install

instead of sudo make dkms .

To enable this driver, use the command:

sudo modprobe 8192cu

Finally, update /etc/modules with this command before you reboot:

echo '8192cu' | sudo tee -a /etc/modules

Source: github.com/dz0ny

Also: https://askubuntu.com/a/395826/167115

3
  • Unfortunately, no luck. sudo modprobe 8192cu command gives the error: modprobe: ERROR: could not insert '8192cu': Device or resource busy. – Marek Lipka Apr 29 '15 at 20:11
  • 1
    Ok, it's because I had probably trail of attemption of solving this (or previous) issue in my /etc/modules. After I cleaned this file and rebooted the system, everything works properly. So thank you very much for your time and I finally have the opportunity to accept the answer after long presence on StackExchange. :) – Marek Lipka Apr 29 '15 at 20:18
  • Also, hard installation is not recommended and the DKMS method is preferred as the DKMS method will automatically install with a new kernel update whereas a hard install will require the driver be reinstalled each time a new kernel is installed. – mchid Apr 29 '15 at 23:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.