3

Ahoj all together.

I'm a proud owner of a Logitech TK820 keyboard with multi touch pad.

After buying it it worked out of the box, also multitouch, which is implemented nicely in Gnome 3.

At some point it stopped working, though: My multimedia keys wouldn't work any more, also multi touch is limited to 2 fingers for scrolling up and down.

I found some related forum posts, but none came close to my problem.

showkey doesn't recognize any keypress for the multimedia keys.

And in /proc/bus/input/devices I'm having 2 entries for that keyboard:

I: Bus=0003 Vendor=046d Product=4102 Version=0111
N: Name="Logitech TK820"
H: Handlers=sysrq kbd event5
[…]
I: Bus=0003 Vendor=046d Product=4102 Version=0111
N: Name="Logitech Wireless All-in-One Keyboard TK820"
H: Handlers=mouse3 event18

Any help is appreciated.

7
  • Installed solaar, but it didn't change anything, also not after reboot and re-pairing.
    – Andy
    May 4 '15 at 20:44
  • Would you elaborate how was multitouch working under gnome-shell? With solaar I can get the F1, F2, etc. work directly, but have no multimedia keys May 28 '15 at 1:35
  • Sure: 2-finger-tap: right click, 3-finger-swipe horizontally: back or forward in history (browser), 3-finger-swipe vertically: open/close gnome overview, 3-finger-tip: middle mouse click, 4-finger-swipe horizontally: maximize window in left/right half, 4-finger-swipe vertically: open notification bar (gnome-shell < 3.16)
    – Andy
    May 28 '15 at 11:05
  • @Andy did you upgrade to 15.04?
    – rahi
    May 28 '15 at 16:51
  • 1
    @EdVillegas multitouch differences in Gnome 3.16 are: 3-finger-swipe up opens workspace/window overview, down opens apps-overview. both then toggle between apps- and workspace-overview. 4-finger-swipe down toggles notifications/calendar
    – Andy
    Jun 23 '15 at 9:32
3

I have the same keyboard and the multi-touch gestures had driven me crazy for some time. Out of the box they were working, then at some point they were gone. I've tried everything, but nothing worked. After some time without any reason they were back and then gone again.

In the end I've found the reason. If you click and hold the "Fn" key and left click you can enable/disable the multi-touch gestures. It's a common combination that can occur while you are trying to ctrl+click so just remember it and try it again if you find that gestures are gone.

3
  • Holy crap! How did you find that out? And for both of us: By which chance would we accidentally have switched that function on?
    – Andy
    Sep 30 '15 at 9:20
  • Hm actually that only switches off multi touch, and not the media keys. Ergo there was another problem aside.
    – Andy
    Sep 30 '15 at 9:24
  • You save my day! Jun 2 '19 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.