9

I installed XAMPP in my Ubuntu laptop and I used to work with it without a problem. Just starting the server with:

sudo /opt/lampp/lampp start

Then, I tried to install a software that needed an apache server and probably something screwed it. Now, each time I run the command, I have this output:

Starting XAMPP for Linux 5.6.3-0...
XAMPP: Starting Apache...fail.
XAMPP:  Another web server is already running.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.

What I have to do, is to run the sudo /etc/init.d/apache2 stop and then start the lampp again. This means that the apache2 is running all the time. Is there any way to solve it without destroy the lampp installation too?

0
25

Open your terminal and run these commands:

sudo /etc/init.d/apache2 stop   
sudo /opt/lampp/lampp start

Replace /opt/lampp/lampp with the directory where LAMPP is located in your case.

1
  • 6
    And after the next reboot?
    – A.B.
    Nov 11 '15 at 11:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.