1

I am trying to install Matlab 8.01 (64-bit installer) on my Ubuntu 15.04 (64-bit). After typing,

sudo ./install

Matlab installer starts and installer appears but within a few seconds it disappears with following information at the Terminal.

Exception in thread "main" com.google.inject.ProvisionException: Guice provision errors:

1) Error in custom provider, java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

... [Some more technical information]

... 62 more

I already installed

default -jre

Please guide me. I am really desperate to see Matlab running on my Ubuntu.


EDIT:

Matlab Folder has bin/glnxa64 folder. So this is a 64-bit installer?

1

This is a very good guide page for me and if you follow it you will get Matlab installed. They are discussing the Java problem there too.

My understanding is that the Matlab version you are using is old and that you have installed java but not the java development kit (jdk). Probably you will need to either install a newer Matlab version or install an older java (java 6),

To see the version of java installed use the command:

java -version

or

file /etc/alternatives/java /etc/alternatives/javac

Here and here you can find how to install java.

To get a more verbose output from Matlab add -v to the installation command.

sudo /<matlab_directory>/install -v

Hope this helps you.

2
  • I followed your instructions to install JDK and it is successfully installed. But still the same error is showing on terminal. – a.s. Apr 29 '15 at 4:44
  • First link has solved the installation issues. No need to install Java as matlab installer has its own java resources. – a.s. Apr 29 '15 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.