5

I use OS X Yosemite 10.10.2 and have VMware Fusion 7.1.1 where Ubuntu 14.04 has been installed. Moreover, I have installed VMware Tools patches.

Copy and paste between Mac and Ubuntu using keyboard shortcuts (Command+C then Command+V) worked fine before. I don't know if it is because of the recent upgrade from VMware Fusion 6.x to 7.1.1 or the installation of the VMware Tools patches, but copy and paste does not work any more. Here are some screenshots of the settings:

enter image description here enter image description here

Could anyone help?

6

First verify that "Enable Drag and Drop" and "Enable Copy and Paste" are enabled in the "Isolation" settings.

Then, execute the following commands in Ubuntu :

  1. sudo apt-get autoremove open-vm-tools

  2. Install VMware Tools by following the usual method (Virtual Machine --> Reinstall VMWare Tools)

  3. Reboot the VM

  4. sudo apt-get install open-vm-tools-desktop

  5. Once again, reboot the VM, after the reboot copy/paste and drag/drop will work!

2
  • 2
    sudo apt-get install open-vm-tools-desktop fixed it for me. Apr 12 '18 at 19:54
  • I can't get this to work with Fusion 12
    – Chris F
    May 26 at 16:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.