I am completely new to linux so I need things spelled out for me. I'm trying to mount an iphone 5s with ios 8.3 to Ubuntu 14.04 running Nvidia drivers.

  • The thing is, with Apple devices, you will probably want to use latest Ubuntu releases bor better results. Not saying it will work but mounting Apple devices has been posible since Ubuntu 10.04...until iOS updates and break support, and then a new Ubuntu release bring it back and then an ending story.
    – xangua
    Apr 29, 2015 at 1:28

4 Answers 4


iOS 8 requires libimobiledevice-1.2, which is not available as packet for 14.04 imho. Instructions on how to install here


First, let me apologize for this information not being as complete as I would like it.

The following is confirmed to work on Ubuntu 15.04 (Vivid Vervet):

  1. Install the required support libraries:

    sudo apt-get install libimobiledevice-utils usbmuxd ifuse

  2. You will want to reboot due to udev entries updated per "usbmuxd".

  3. The following commands are used to pair you iPhone/iPad devices to your PC:

    mkdir /media/iphone
    chown {your userID}:{your groupID} /media/iphone
    chmod 775 /media/iphone
    /usr/bin/idevice_id -l

    (this command displays a 40 character identifier unique to your idevice)

    /usr/bin/idevicepair -u ## pair
    ifuse /media/iphone -u 

    ...or you can simplify the last two lines by typing this:

    /usr/bin/idevicepair -u \`/usr/bin/idevice_id -l\` pair
    ifuse /media/iphone -u \`/usr/bin/idevice_id -l\`

This works for me :)

  • 2
    This no longer works in Ubuntu 16.04/iOS10. Not sure which is the problem since I haven't mounted since 14.04/iOS9. Error after running ifuse /media/iphone -u ##: "GnuTLS error: Error in the pull function. / Failed to connect to lockdownd service on the device. / Try again. If it still fails try rebooting your device."
    – Ben Y
    Oct 14, 2016 at 13:03
  • after installing libimobiledevice this worked for me - im using kubuntu
    – Tharindu
    Mar 27, 2017 at 5:19

idevicepair and ifuse are the tools I used on Kubuntu 15.10 to mount my iphone 6 and transfer 40GB of pictures.

thank you


In my case I am using kubuntu 16.04 and an iPhone 4s.

After installing the libraries like explained in previous questions and ifuse, when using ifuse my iPhone would still not mount. It wouldn't neither charge although it vibrated when connecting to my computer.

I solved this problem by restarting the usbmux process (http://www.phenomtech.net/2015/02/fix-non-charging-iphone-through-usb-on-ubuntu-linux.html):

ps aux | grep usbmux
sudo kill -9 xxxx
sudo usbmuxd -u -U usbmux

Where xxxx is the process id seen using "ps aux".

After restarting this process I could mount using ifuse (and access my photos) and my phone was charging too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.