12

When I open a terminal in Ubuntu 15.04, it shrinks to 1 character by 1 character. I can use the corner resizer to make the window bigger, but it immediately shrinks to 1x1. There are a few x,y combinations that allow the window to stay at the desired size, but if you're off by a pixel, the window shrinks to 1x1.

There is another question, Gnome-terminal in Kubuntu shrinks to minimum size, that is basically the same thing, but in KDE. I tried to follow the instructions:

In KDE, go to System Settings. Return to the overview if you are not already there. In the Workspace Appearance and Behavior section, click Window Behavior. In the area to the left, click the Window Rules icon.

but, there is no Workspace Appearance and Behavior section. I couldn't find a similar setting in ccsm, gnome-tweak-tool or unity-tweak-tool.

% dpkg-query --show compiz
compiz  1:0.9.12.1+15.04.20150410.1-0ubuntu1
% dpkg-query --show unity
unity   7.3.2+15.04.20150420-0ubuntu1

The problem appears to be in the Adwaita theme. To avoid this problem, I opened the System Settings/Appearance and set the Theme to Ambiance (default).

  • I think a similar setting is in the normal Unity System Settings. – TheWanderer Apr 29 '15 at 1:10
  • 1
    Well...what is it? Where is it? I looked under the Appearance icon, and didn't find anything relevant. None of the other icons appear to be relevant. – Chelmite Apr 29 '15 at 4:38
  • I'm trying to think of it. I can't remember. – TheWanderer Apr 29 '15 at 10:49
  • I've this problem too, if you've found any solution, please share it here. – frogatto Apr 29 '15 at 16:53
  • Same problem here, I use Terminator in the meantime. – Romain May 4 '15 at 7:07
2

Unfortunately this bug has not yet been resolved. As you can see, this is due to an issue with using Adwaita, BUT:

I found that switching to the Vertex theme was not only an acceptable solution, but I think I prefer it to other options right now:

Vertex Theme

Instructions are here: Github Installation Section, but I simply used the xUbuntu packages here for Ubuntu 15.04; drop to shell and do:

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_15.04/ /' >> /etc/apt/sources.list.d/vertex-theme.list"
sudo apt-get update
sudo apt-get install vertex-theme

I then wanted to get the matching icons, and so used this for reference:

sudo add-apt-repository ppa:moka/stable
sudo apt-get update
sudo apt-get install moka-icon-theme
mkdir ~/.icons
cd ~/.icons
git clone https://github.com/horst3180/Vertex-Icons.git 

Hopefully you already have Unity Tweak Tool (sudo apt-get install unity-tweak-tool) installed. Then simply go in to its Appearance section -> Theme and pick Vertex-dark for your Theme and then pop over to Icons and select Vertex-icons if you like.

FYI, Breeze icons also look nice or perhaps just Moka itself without Vertex. If you like the icons from the screenshot above, use Ardis.

| improve this answer | |
  • Sadly, also with the Vertex Theme this problem isn't solved. At least not with remmina and synaptic/update-manager's windows, where it shows you the progress of the installation - when you let it show the details. It always gets back to minimal size :/ EDIT: I guess that's a different error. Thanks for the Vertex theme, tho, love it. – Meng Tian Jul 7 '15 at 7:57
-1

Open terminal (CTRL+ALT+T)

Hold ALT then + T and use some of the options to reset the size.

| improve this answer | |
  • I am sorry, but I don't see what Alt+T should do... No reaction of my gnome-terminal window on 15.04 for me. Could you please explain what should happen? Ideally with a screen shot, if possible. You can upload an image to imgur.com manually and paste the link here, as you don't have enough rep points yet to insert it directly. – Byte Commander May 21 '15 at 20:52
  • ALT+T does nothing. If pressed after creating the window and it's shrinking, nothing changes. If pressed after the window is at its minimum size, nothing happens. – Chelmite May 22 '15 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.