2

I recently converted my laptop to Ubuntu 14.04 (two days ago at the time of this posting) and just encountered this problem (an hour or so ago at the time of this posting). The problem is that my Logitech headset is no longer working, but in the weirdest way possible. The sound control tab in the system settings shows the headset as the selected audio device but all the sound is played through the onboard speakers of my acer aspire 4743. all of the other functions of the headset remain the same (microphone and volume controls.). I have already messed around with alsamixer and tried the suggestions of other users but nothing has worked so far, any ideas? I am totally new to Linux and have no idea what might be causing this. Thanks, Eric

  • Update, sevral reboots and an update solved the problem, All is well – Eric Fisher Apr 29 '15 at 17:22
  • I've had this happen with a Logitech H800. Just rebooting fixes it. – wjandrea Jan 26 '18 at 20:32
0

It's only because your hardware mapping is not configured automatically by your Ubuntu. You can solve this manually.

  1. Find whether your system is showing your Logitech USB headset or not.

    Go to Settings > Sound:

    Screenshot: sound settings

  2. This will be here, go to the terminal, type this command:

    xinput list
    
  3. Enable your device by putting its ID at place 13 in code with this command:

    xinput set-prop 13 "Device Enabled" 0
    

    Like this - see the last line:

    Screensot: output of <code>xinput</code> commands

|improve this answer|||||
  • This will disable the device. – Pilot6 Oct 19 '15 at 20:23
  • In my case, I can not see my headset as Output. Would you please guide me to install any specific libraries. I have run Ubuntu 14.04 64bit and Logitech wireless headset H800. – Bhavesh Odedra Sep 6 '17 at 12:45
  • 1
    I only needed Step 1 with my Logitech G533 =) – pzrq Nov 19 '17 at 8:06
  • What does that command actually do? Why does the headset have to be id 13? I've read the man page but it's still not clear. – wjandrea Apr 5 '18 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.