18

"Install VMware Tools" greyed out after installing Ubuntu 15.04 on VMware Player 7.1. I tried checking "No proxy" instead of default "Windows proxy settings" at "File->Preferences->Software updates-> Connection Settings". This did not work either. Is there a way to install VMware Tools?

0

7 Answers 7

37

I had the same issue. Like the answer posted before, I had to shutdown the machine and change both the floppy drive and cd drives to "Auto detect" and then power on the machine.

6
  • Also make sure you select the OS correctly in VMWare settings. When the OS is "other", Install VMWare Tools menu is greyed out. Mar 7, 2018 at 10:24
  • just adding the cd-rom device back worked for me - floppy not necessary
    – JimSTAT
    May 21, 2018 at 15:33
  • Thanks! I did not have to shutdown the machine - the option was non-greyed instantly.
    – thomasa88
    Nov 15, 2018 at 8:12
  • This works, but why? Mar 16, 2019 at 5:33
  • Works, but this is some cringe, VMWare. The answer posted in 2015, we're in 2022 and I just had this issue and it took me an hour to fix this lmao.
    – KulaGGin
    Jan 10 at 17:08
7

I unmounted the two ISOs which were mounted because of the Easy Install. After that I was able to push the "Install VMware Tools" button in the dropdown menu.

5

This worked for me on Ubuntu 16.04

sudo apt-get install open-vm-tools-desktop
5
  • 1
    I think you mean Any supported version of Ubuntu >=14.04 See packages.ubuntu.com/…
    – Elder Geek
    Nov 8, 2016 at 19:30
  • 1
    @ByteCommander Well that command did not work for me, but i found another solution and posted it as answer.
    – Matiss
    Nov 15, 2016 at 11:21
  • @ByteCommander note that it's a different package name.
    – terdon
    Nov 15, 2016 at 17:12
  • 1
    @terdon Is it? Oh, oops... I must have been a little sleepy... Thanks for paying attention.
    – Byte Commander
    Nov 15, 2016 at 19:39
  • +1: Thanks, lifesaver.
    – copper.hat
    Jan 16, 2020 at 5:28
3

You can mount VMwareTools CD image manualy, file path is like this:

C:\Program Files (x86)\VMware\VMware Workstation\linux.iso
1

A good solution for Ubuntu as a VMWare guest is to install the open VMWare tools: This can be done from the command line with the command

sudo apt-get install --install-suggests open-vmware-tools

0

If you add a CD-ROM Drive then you see this option "Reinstall VMware Tools...".

If you don't hava a CD-Rom the option to reinstall the VMware Tools will not be availlable.

-1

What you have to do is simple,

just start a Guest Machine(your VM)

then you will see that the VM -> Install VMware Tools ... option is enabled.

Simple clue - when you starting the Guest Machine you see this dialog box (if you have not checked it out earlier) after clicking OK, VM -> Install VMware Tools ... option is enabled.

You do not need to change anything other than starting a Guest Machine.(No need to change proxy settings in VMware or unmount an image mounted on your guest machine CD/DVD ROM)

Not the answer you're looking for? Browse other questions tagged or ask your own question.