22

What does the error mean and why does it keep showing up at start-up? I reported a bug but nothing changed.

22

Ubuntu has a program called Apport that is responsible for detecting such crashes and upon user consent, report these crashes to developers. This process intends to get the problem fixed by the developers.

However it can be very annoying to common users, and there is no point in showing errors to users when they cannot do anything about it themselves. So you might want to disable them.

The apport system creates crash report files in the /var/crash directory. These crash report files cause the error message to appear everytime Ubuntu boots.

Turn off apport

$ gksudo gedit /etc/default/apport

Just set the value of enabled to 0, and this will disable apport.

enabled=0

Save the file and close it. From the next boot onwards, there should be no error messages ever. If you do not want to restart the system then restart apport from the command line.

$ sudo service apport restart
  • Note that you can temporarily override this setting with sudo service apport start force_start=1. – jvriesem Aug 2 '16 at 21:26
  • Could you elaborate at all on why these errors are enabled by default? If they are relatively useless to the end user it would probably be worth suppressing them and adding a global "report crashes automatically" option which doesn't interface the user at all? – XtrmJosh Feb 6 '17 at 7:34
14

(Writing a new answer, because I can not comment yet.)

Adding to @Vlad Savitsky's answer:

Apport's task is to report crashes to the Ubuntu developers. As such it is benign and should not be simply turned off.

Apport is supposed to show you every problem only once. The issue seems to be that apport itself can become confused and fails to record that it already reported a problem, or forgets that it did. This can lead to whole series of dialogs, which is annoying. This might happen when upgrading the system.

One solution is to delete all crash reports in the /var/crash directory. This command can do that for you:

sudo rm /var/crash/*

Of course, if new crashes occur, apport will notify you about those, which it should.

If apport continues to be annoying, turning it off entirely is a different solution. As Vlad described, you need to

sudo ${EDITOR-gedit} /etc/default/apport

and set enabled=0. To activate that change, on 16.04 and above, a different syntax than just restart is needed to restart apport. 16.04 uses systemd to manage services, so that the systemctl command can be used:

sudo systemctl restart apport

protected by souravc Jan 19 '18 at 6:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.