I don't know when the 15.04 was released but I installed VMware Workstation 11.1.0 and I can't install VMware tools for the Ubuntu guest since VM > Install VMware tools option is disabled. Anybody has an idea ?

  • What happens when you try to install? – Thomas Ward Apr 28 '15 at 10:58
  • VM > Install VMware tools option is disabled. – 3bdalla Apr 28 '15 at 11:26
  • 2
    Did you instruct VMware Workstation to actually download all the ISOs for VMware tools so you could install VMware tools for various releases? That's an option you actually have to go turn on. Alternatively, you can just download the latest VMware Tools from VMware itself inside the VM and then install it. The problem here is VMware isn't part of Ubuntu and is third party proprietary software, so the fact 15.04 was released wtihin the last week or so has nothing to do with it. – Thomas Ward Apr 28 '15 at 11:41

No one is saying this, but I think it needs to be mentioned.

In recent releases of Ubuntu (definitely in 16.04 LTS!!!), you should no longer install the VMware tools from the "Install VMware Tools menu". Instead:

sudo apt-get install open-vm-tools-desktop

The -desktop part is important! If you simply install open-vm-tools it will not work as expected!


I had the same problem and found a solution: Change the setting in the VM of the floppy from virtual one to physical and it will work.

(However after I installed VMware Tools, unity mode still not working, I just dont understand why they make working with Linux so difficult, I installed the tools on windows in one click and in less than a minute.)


Just go to VM menu and click Install VMware Tools. Then, extract *.tar.gz into home folder.

Open a terminal and change directory into vmware-tools-distrib, then run

sudo ./vmware-install.pl -d

to accept all default settings. If you want to force then use -f switch:

sudo ./vmware-install.pl -d -f

Thanks for the tip.

In my case Install VM tools was grayed out.

So i power-off VM and remote floppy drive for the VM. After restart VM tools option is enable :)

I am using VMWare workstation 11.1.0



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.