I have just installed Ubuntu 15.04. I tried to connect with my broadband DSL connection. When I entered the cable it was showing that it could recognize the cable. Then from edit connection I added a new DSL Network Connection and configured with my username and password. Then when I tried to connect through the new configured DSL connection it prompts up a message saying "Connection activation failed. (1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/5' failed in libnm-glib.". Here is the screenshot of the prompt: http://pasteboard.co/3HlwTSl.png

What is the problem? How do I resolve it?

  • Are you sure you added the right 'security' key?
    – Ron
    Apr 28, 2015 at 8:47
  • It didn't asked me any security key while installing it. Apr 28, 2015 at 8:50
  • @K.K Patel <br> i cant connect to internet at all <br> can you give me link to .deb package of network-manager Jun 6, 2015 at 12:17

2 Answers 2


It seems that network-manager is broken.

Download network-manager packages by following command while internet connection is active.

sudo apt-get install -d --reinstall network-manager network-manager-gnome

Purge network-manager packages.

sudo apt-get purge network-manager-gnome network-manager

Reboot the system and re-install it.

sudo apt-get install network-manager-gnome network-manager
  • Didn't help me. Still getting the same message. Apr 17, 2017 at 20:05

Had the same problem in Ubuntu Mate 15.04. "sudo pppoeconf" in terminal got a working DSL connection. It asks several configuration questions, then it is possible to connect with "pon dsl-provider" and disconnect with "poff dsl-provider". Added two buttons with these commands on panel and removed network-manager from startup apps for now.


Not the answer you're looking for? Browse other questions tagged or ask your own question.