I recently upgraded my system from 14.10 to the new version (I know, my second mistake, the first one was the upgrade to 14.10), 15.04. Let's say that since I did that, last Friday, I didn't notice major drawbacks (except for some strange lock-screen issue) until today.

Yesterday evening I forgot to shut down the computer and today after I logged in I started to see some strange increased CPU usage. There was a /usr/lib/apt/methods/http process that took 100% of the CPU constantly. Seeing this, I thought doing a software update (graphically) would terminate the process, but instead I got a message like apt-get cannot exit, or something like that. I thought perhaps some other process locked apt, so I tried to unlock it by removing the lock files /var/lib/apt/lists/lock and /var/cache/apt/archives/lock but nothing changed, the process was still running.

Then I thought perhaps a reboot will fix the issue, so I rebooted the computer. After the reboot the /usr/lib/apt/methods/http process was indeed gone, so I tried updating the software sources manually to see what was going on. When I ran apt-get update I noticed that at the end the update is stuck with a line such as 100% [15 Packages 25.6 GB/25.6 GB 100%], where the total amount of data (the size in GB) is increasing, it does not stop. I had to interrupt the command because I didn't know what it was doing.

What should be the problem ? How can I fix this ?

  • Something may be wrong with your software sources. Carefully go through /etc/apt/sources.list and everything in /etc/apt/sources.list.d for deb statements that look suspicious, or edit your question and add all the deb statements. – Jos Apr 28 '15 at 7:58
  • my sources.list contains only official sources, everything else was discarded when I did the upgrade – misterjinx Apr 28 '15 at 9:00
  • One way of debugging this would be to comment out all the deb lines except one, and see where the apt-get update command gets stuck. That includes any lines in the sources.list.d folder. To narrow it down, do a "binary search" - comment the first half, if that gets stuck the harmful deb line must be in the second half, etc. – Jos Apr 28 '15 at 9:40
  • I had to disable the universe, multiverse and restricted repositories in order for the update to finish. I hope they'll fix this issue. – misterjinx Apr 28 '15 at 11:08

I had the same issue. It seems as there are some problems with the repositories for universe and multiverse. After I removed all of these sources the update runs again without any issue.


| improve this answer | |
  • I disabled universe, multiverse and also restricted and now the update finished. I hope they'll fix this issue. – misterjinx Apr 28 '15 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.