0

When I try to install php5-intl, I got this error message. What does mean of this message? Anybody can help me to explain this message? Should I remove php5-common first? or anything else?

root@dremi-ubuntu-X450JF:/var/www/html/cakephp3# sudo apt-get install php5-intl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-intl : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4) but 5.5.9+dfsg-1ubuntu4.4 is to be installed
E: Unable to correct problems, you have held broken packages.
root@dremi-ubuntu-X450JF:/var/www/html/cakephp3# 

Here is the output of apt-cache policy php5-intl php5-common

    root@dremi-ubuntu-X450JF:/var/www/html/cakephp3# apt-cache policy php5-intl php5-common
php5-intl:
  Installed: (none)
  Candidate: 5.5.9+dfsg-1ubuntu4
  Version table:
     5.5.9+dfsg-1ubuntu4 0
        500 http://id.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
php5-common:
  Installed: 5.5.9+dfsg-1ubuntu4.4
  Candidate: 5.5.9+dfsg-1ubuntu4.4
  Version table:
 *** 5.5.9+dfsg-1ubuntu4.4 0
        100 /var/lib/dpkg/status
     5.5.9+dfsg-1ubuntu4 0
        500 http://id.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
You have new mail in /var/mail/root
root@dremi-ubuntu-X450JF:/var/www/html/cakephp3# 
1

There is something wrong in your APT sources.

You can see that because of the version of your php5-common packages which is 5.5.9+dfsg-1ubuntu4.4 whereas you php5-intl package version is only 5.5.9+dfsg-1ubuntu4.

Also, your current php5-common package version comes from /var/lib/dpkg/status indicating it can not be associated to any currently known APT source.

Therefore, it could mean that you used an APT source to install php5-common and removed it after then, or that your package lists are not up to date.

I recommend:

  • checking your /etc/apt/sources.list
  • running apt-get update (it should be done before installing any package)
  • I have checked /etc/apt/sources.list, what should I do next? after run apt-get update, still not work for apt-get install php5-intl – Muhammad Khairul Azami Apr 28 '15 at 5:48
  • According to packages.ubuntu.com/php5-common you should get the 5.5.9+dfsg-1ubuntu4.9 version for php5 packages in Trusty, and certainly not 5.5.9+dfsg-1ubuntu4 which is obsolete by 9 versions. If the apt-get update command showed no error, I would recommend you to try with another Ubuntu mirror. – progfou Apr 28 '15 at 5:53
  • OK, I'm trying to update from another mirror. – Muhammad Khairul Azami Apr 28 '15 at 6:11
  • I have done for run apt-get update, after change mirror to kambing.ui.ac.id/ubuntu. then try again to run apt-get install php5-intl, but there is no changes. – Muhammad Khairul Azami Apr 28 '15 at 6:14
  • What is the new result now for apt-cache policy php5-intl php5-common ? – progfou Apr 28 '15 at 6:21
0

According to the error message, it may be because you choose to hold some packages, forbidding them to get upgrades.

You can check for hold packages with these commands:

  • If you are using aptitude: aptitude search "~ahold"
  • If you are using apt-get: dpkg --get-selections | grep 'hold$'
  • hello progfou, i try to run aptitute search "~ahold", the output is root@dremi-ubuntu-X450JF:/var/www/html/cakephp3# aptitude search "~ahold" The program 'aptitude' is currently not installed. You can install it by typing: apt-get install aptitude You have new mail in /var/mail/root so, i type apt-get install aptitude. then try to apt-get install php5-intl again, still not work. – Muhammad Khairul Azami Apr 28 '15 at 5:13
  • Well, you don't really need aptitude. If you are not using aptitude, just use the second line to check for hold packages. What is the answer from the second one? – progfou Apr 28 '15 at 5:18
  • the second line didn't show anything on console – Muhammad Khairul Azami Apr 28 '15 at 5:44
  • So you don't have any hold package. It's more likely an APT source problem, hence my second answer. :-) – progfou Apr 28 '15 at 5:48
  • ok, but I don't know about the APT source problem. – Muhammad Khairul Azami Apr 28 '15 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.