I have recently installed Natty on my Lenovo Ideapad s10-3 netbook. I have a problem: while I'm able to put my computer to suspension, it just won't wake up when I open the lid or press a key (any key).

Some of the indicators show activity (power, battery and wireless connection), but the display won't get turned on and the HD stops working. At the end, I always have to brutally power of the machine by holding power.

What could be causing this errror? I have an Ideapad s10-2 (the predecessor to s10-3) and it has absolutely no problem with the suspend option.

I've noticed that at the login screen - before logging in - I can suspend and resume without problems. When I log in the suspend function fails. I then tried to log out and suspend but it didn't resume. The other day I was at a friends house and logged in. I wasn't connected to his wireless network since it wasn't on my list of networks (fresh install of Ubuntu). I then suspended and resumed - when logged in - with no problems at all. After connecting to his network it failed again. That made me try suspending and resuming after disabling wireless connections by flicking off the switch on the side of the netbook. No dice. Next up I tried disconnecting from the wireless network from the connections applet in the status bar and then suspending and resuming. No dice this time either.

I tried Sebastian's answer, but it doesn't work. I did update the grub and all. No dice. It starts to annoy me big time. Any suggestions??


try uswsusp.

sudo apt-get install uswsusp

After installation, my IdeaPadS10-3 shows ...

$ sudo s2ram -n
Machine is unknown.
This machine can be identified by:
    sys_vendor   = "LENOVO                          "
    sys_product  = "S10-3           "
    sys_version  = "Lenovo                  "
    bios_version = "2ACN37WW  "

"Machine is unknown." But it worked by using `-f'(--force) option

sudo s2ram -f

as far as the nohpet option goes, it seemingly does the trick. Only problem is that it causes various problems for me on resume - e.g. a nonfunctioning mousepad.

I thank you all for your responses, though I happened to brick my Ideapad two days ago after having disassembled it. Now, obviously, nothing works :(


Alternatively, kernel parameter nohpet seems to do the trick for some users.


I have a Lenovo Thinkpad and had the same problem resuming from suspend in natty. reinstalled oneiric and the problem seems to be solved


This is a known problem of S10-3. You probably installed it through a USB Stick and had to add several grub commands. You just have to add the following to the boot kernel option:


This should fix your problem. It is a problem referring to the Suspend2Disk and Suspend2Ram.


This may be premature, but I believe we've found suitable fix for Precise. I've put a test kernel up here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/871891


s2ram -f failed for me.

intel_idle.max_cstate=0 has at various times worked for me, but now under precise (and recently under oneiric) not.

nohpet (just tested) doesn't work for me

lucid is still suspend/resuming like a dream (but isn't a real option for me).

However I really think that the key to this lies in that, even in lucid, you must hit the power switch after opening the lid, and hit it within 5 seconds, to get resume to work. LID is in /proc/acpi/wakeups, but I think therein lies the root of the complete failure on later kernels.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.