1

Just upgraded to Ubuntu 15.04 from Ubuntu 14.10. When I try to connect through the GUI to a password protected wifi network I cannot click on the 'connect' button D:

Any quick fix?

enter image description here

The wireless card works perfectly fine and I am able to connect to wireless networks that do not require a password input... the GUI that I am referring to is the ubuntu pop-up (in the screenshot) that asks me to insert the password. As you can see the "connect" button becomes "red&gray" and I cannot click on it...

Many thanks in advance!

  • Not a fix, but a good start nevertheless: askubuntu.com/questions/425155/…. Also, can you clarify why you can't click Connect. Is anything wrong? – mikewhatever Apr 27 '15 at 18:12
  • what GUI ? what's its name ? Are you using kubuntu ? look at journalctl -f output in a terminal to try to pin-poin the source of the problem. – solsTiCe Apr 27 '15 at 18:55
  • I am using ubuntu. The wireless card works perfectly fine and I am able to connect to wireless networks that do not require a password input... the GUI that I am referring to is the ubuntu pop-up (in the screenshot) that asks me to insert the password. As you can see the "connect" button becomes "red&gray" and I cannot click on it... – Qerubin Apr 28 '15 at 7:36
  • Also, I guess this guy has the same issue: askubuntu.com/questions/614894/… – Qerubin Apr 28 '15 at 7:37
  • For now you can make use of rob's comment in the following article. It's working for me. askubuntu.com/questions/613764/cant-enable-wifi-on-ubuntu-15-04 – Sam May 4 '15 at 12:24
1

I would make sure that:

  1. I typed the right password (silly, but happens more often than not!)

  2. restart network manager

  3. delete saved connection and add it back again (make sure to select the right authentication system)

| improve this answer | |
  • 1. That's not the case, I cannot click that button regardless of what I write. 2. Does not help... 3. I will try asap but this happens also for a network to which i Connected just fine until the upgradr, than everything went tumbling down... D: – Qerubin Apr 28 '15 at 16:53
1

I just fixed it by deletin the connections and creating them again, this time I unticked the option "ask everytime for the password".

| improve this answer | |
0

In Ubuntu 14.04 I can't connect if The Key is showed. But I dont know if that is the case, maybe try retyping the password or rebooting the Internet

| improve this answer | |
  • That's not the case and rebooting the internet does not help... – Qerubin Apr 28 '15 at 7:33
0

I had this exact same problem in ubuntu and got it to work today.

The way I got it to work was installing the cinnamon desktop. (I realize this may not be the place to post this, but it worked for me.) This was a crucial problem as I couldn't use my laptop at work.

From there I had the same issue..when I was prompted to enter a password it would not let me click. I think it may be a permission issue.

I right clicked network settings tab (again in Cinnamon) and it allowed me to enter and save a password. Now I am connected to the wifi.

This may not be the ideal series of events to use, but this is what I did and it is now working.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.