the question says it all i just cant get into the terminal and I've tried using Ctrl + Alt + T, but it still wont pop up please help !

  • Can you find it from unity dash (press the Super key and type terminal) ?
    – heemayl
    Apr 27, 2015 at 17:07
  • How did you solve it? Please add that info as an answer and select that as the accepted answer..this would help all future readers..
    – heemayl
    Apr 27, 2015 at 17:15
  • 3
    Please do not edit the question with "solved" but add an answer and accept it.
    – Rinzwind
    Apr 27, 2015 at 17:20
  • 1
    Do you still have the "gnome-terminal" package installed?
    – BDRSuite
    Apr 27, 2015 at 20:04
  • What was the outcome here? is gnome-terminal installed or not? Jan 13, 2017 at 19:43

4 Answers 4


You can use ALT + F2 and enter gnome-terminal.

  • it makes me login and my log in doesnt work for some reason
    – user258542
    Apr 27, 2015 at 17:05
  • 2
    @user258542 What does the login prompt look like? I recommend editing your question to provide a detailed description of this, and also (if possible) a screenshot. It's very strange to have to log in to run the gnome-terminal executable. Or do you mean that you are you pressing Ctrl+Alt+F2 (which will switch you from tty7, where the GUI is running, to tty2, a virtual console with a non-graphical login prompt)? Apr 27, 2015 at 18:00

I had the same problem. It seems the gnome-terminal-server program is the problem. If I run it:

    $ /usr/lib/gnome-terminal/gnome-terminal-server
    Non UTF-8 locale (ANSI_X3.4-1968) is not supported!

So a simple fix is to start gnome-terminal as follows:

    $ LANG=en_US.utf8 /usr/bin/gnome-terminal

You can add the LANG=en_US.utf8 to your ~/.bashrc by adding the following line to it:

    export LANG=en_US.utf8

and logging out and logging back in. (or rebooting) (Note, that if you are not in the USA, substitute your own locale, as long as it ends in utf8)

Now, as to why either gnome-terminal-server requires this or why the proper LANG isn't set, I don't know. Strangely, my Ubuntu box at home has no problem running gnome-terminal, but my work box does. I have compared the two systems and cannot immediately find the difference. (I don't set the LANG variable on the machine that works!)

Oh, and on the system where gnome-terminal doesn't work, I simply started xterm instead... Not perfect, but good enough to get a terminal running to examine things.


I had the same problem as the initial question. Since my initial upgrade failed, I installed 15.04 by first removing the old installation in the initial install process. After installation terminal would not launch. Still it was running several times according to System monitor.

In another discussion someone suggested that if you check System Settings > Language Support the system suggest that internationalisation or language support installation was not finalised. After finalisation (I'm using three languages) the terminal started working.


To fix this problem, you have to

  1. Find out your user name. It is NOT your display name. Most likely it won't contain capital letters, nor spaces. If you remember it from somewhere, it is good, jump to 5. If not, do as follows:
  2. Press Alt+F2, then enter "gedit" in the window. It will something like "Text Editor" or so, open it.
  3. Click Open, then Other Documents, then browse to Computer, and select the file /etc/passwd.
  4. Search for the line that has the number 1000 after x, that is, [YOUR_USER_NAME]:x:1000:33:Default User,,,:/home/[YOUR_USER_NAME]:/bin/bash or something similar. Look for the 1000, and that line will start with your user name.
  5. Switch to "regular tty" (character console) using Ctrl+Alt+F1. Please remember in time that you can switch back with Ctrl+Alt+F7 anytime.
  6. At the login prompt, enter your user name (found above or known), then your password. You will get logged in to a "full screen terminal".
  7. Enter sudo -s at the prompt. (You can also use "sudo su", if you read that on the Internet, but it is better knowing what you actually do; -s is the "shell" switch, it is DESIGNED for this function.) Then enter your password - again.
  8. At the root prompt # enter dpkg-reconfigure locales. You will have a scary blue window with a grey area, and a lot of locales available under Locales to be generated:. Use the cursor keys to pick en_US.UTF-8 UTF-8 and en_US UTF-8, plus anything else you might need (but be sure that locales having your language AND ending in UTF-8, if it is not US English, also be selected). You should use space bar to toggle a locale.
  9. When all picked, press TAB to select "Ok", and press ENTER.
  10. Now you have the window for selecting the default locale for the system. Pick one from the list, but do not leave it on None, then press ENTER again.
  11. Now the system will generate your selected locales and configure the system accordingly.
  12. When all this is done, you should reboot your computer to make sure that the environment will be updated. For this, switch back to the graphical terminal with Ctrl+Alt+F7 then reboot as usual, or just enter reboot at the root prompt. In fact, in the last step, restarting the display manager with service lightdm restart should suffice, but if not, you will need to reboot anyway.

Now your terminal should operate as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .