3

I've recently upgraded from utopic to vivid (14.10 to 15.04) and whilst there are a few small issues the main thing is that my touchpad (logitech t650) is not working as it was, specifically I can no longer use a 3 fingered swipe left or right to move backwards or forwards in a browser, or nautilus when looking through files, other than that the touchpad works fine, although it does need tweaking as it isn't as smooth to use as it was in utopic.

I have tried numerous things and had no luck, I've already upgraded the firmware by the way, the annoying thing is I can plug it into my wifes system (running 14.04) and it works perfectly with no configuration (including 3 fingered gestures), this was also the case in utopic but not for vivid, as far as I can tell it no longer supports 3 fingered gestures in vivid, I've tried programs like easytouch, touchegg and some others but all of them don't see the 3 fingered gestures, I also used geisview to see what the touchpad is capable of, and according to that it's not capable of 3 fingered gestures.

In all honesty I'm at a bit of a loss as to what it might be, so any ideas would be appreciated.

Edit :

Since writing this I have been doing some experimenting, and I have found at least for me a way to get 3 fingered swiping, I basically use it for browser navigation, but with more tweaking it might be possible to get a lot more of the touchpads functions working.

After searching I came across this - multitouch gestures it's taken a bit of messing about with, but that's more my lack of knowledge than anything else, I did have some issues when running some of the commands (specifically the make commands) turns out this might be down to glibc, but I found that using this source solved the make issues clone from here if having make issues

I still have some issues with the touchpad, but this seems to be a step in the right direction, hope it helps.

  • Link to "multitouch gestures" is dead now. – Mark Stosberg Oct 19 '18 at 17:06
4

In kernel 3.19 (as included with Ubuntu 15.04 Vivid) the Logitech HID++ driver got rewritten to improve support for certain Logitech devices. This shifted processing of events from the hardware (the touchpad) to software (the Linux input driver stack).

This results in the Logitech T650 touchpad not sending keyboard events such as Back for three fingers. Since there is no multi-touch driver that processes gestures, you do not get the event either.

Workarounds:

  • Install a kernel version before 3.19 (or just the hid-logitech-dj driver from previous versions).
  • Enable both reporting of gestures as well as raw events. Since the events reporting is very sluggish after this method, I won't explain it here.

A forward solution should recognize the multi-touch functionality of the Logitech T650 touchpad and then generate appropriate events for gestures.

| improve this answer | |
  • I'll continue looking for a fix. – Lekensteyn Apr 27 '15 at 15:50
  • Thank you for your reply, I think at this point I'm probably going to go back to utopic, there are some other unrelated issues I'm having that I can't seem to fix at present. – techno-mole Apr 27 '15 at 17:49
  • @Lekenstyn can anything be done using xinput --set-prop? – rahi May 6 '15 at 14:02
  • @rahi No you cannot, this is a kernel driver change which changed the reported information. Only if a userspace driver interprets those touch events, there is a chance to support the gestures. I don't know a working one. – Lekensteyn May 6 '15 at 17:18
  • 1
    I have recently discovered libinput-gestures which on ubuntu 16.04 makes the touchpad usable again. libinput-gestures can be found here - github.com/bulletmark/libinput-gestures it's easy enough to install and configure and I think it may work for other touchpads. – techno-mole Sep 5 '16 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.