0

I recently installed TADS 3 Workbench using Wine and accidentally chose the option to create file type association. Now, all my plain text files have a rather garish icon replacing their default ones.

enter image description here

What I have tried:

  1. Uninstalled TADS

  2. Removing mimeinfo.cache (rm ~/.local/share/applications/mimeinfo.cache) as well as any .desktop files there created by wine

  3. Added

    <generic-icon name="text-x-generic"/>

    <icon name="text-x-generic"/>

to /usr/share/mime/packages/freedesktop.org.xml under <mime-type type="text/plain">

  1. Deleted rm ~/.local/share/mime directory.

  2. Removes entire wine prefix.

However, the icons are still the same. Any idea how to mend this?

2
  • Have you tried restarting? Just curious.
    – user292611
    Commented Apr 27, 2015 at 14:59
  • Yes, I did restarted. Didn't help
    – strNOcat
    Commented Apr 27, 2015 at 17:54

1 Answer 1

0

Wine store it's icons in ~/.local/share/icons/hicolor. And becuase Wine hates you, it stores all the filetype icons not in mimetypes directory but in app directory of every resolution. In my case this file was named text-plain.png but that will depend on it's mimetype. Once you delete those files and reboot the computer, the icons should return to usual (Of course, we have simply removed the image files; somewhere, there is still an entry of that image to be used as the icon)

Another hit-and-miss solution is to change the icon theme.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .