2

my aircrack-ng suite was working correctly until i updated to 15.04 i unsintal evrything and intsaled again form repositories to discard weird stuff and the problem is stil there:

 sudo airmon-ng 


Interface   Chipset     Driver

wlan0       Atheros AR9565  ath9k - [phy0]

    kcdtv@profezorapplestruff:~$ sudo airmon-ng start wlan0


    Found 5 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!

    PID Name
    595 avahi-daemon
    599 NetworkManager
    678 avahi-daemon
    749 wpa_supplicant
    795 dhclient


    Interface   Chipset     Driver

    wlan0       Atheros AR9565  ath9k - [phy0]SIOCSIFFLAGS: Le nom n'est pas unique sur le réseau

                    (monitor mode enabled on mon0)

    kcdtv@profezorapplestruff:~$ sudo airodump-ng mon0
    ioctl(SIOCSIFFLAGS) failed: Name not unique on network

I tryed to habilitate and deshabilitate network manger etc...

the only walk around i found is to bring down the interface and activate mode monitor with iwconfig Which does not satisfy me. if i install aircrack-ng svn version i get the same fail but a more details in the shell:

    kcdtv@profezorapplestruff:~$ sudo airodump-ng wlan0mon
[sudo] password for kcdtv: 
ioctl(SIOCSIWMODE) failed: Device or resource busy

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211,
ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead.  Make
sure RFMON is enabled: run 'airmon-ng start wlan0mon <#>'
Sysfs injection support was not found either.

My host file look like that

    127.0.0.1   localhost
127.0.1.1   profezorapplestruff

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

and efectivly the device is til in managed mode:

/sbin/iw dev
phy#0
    Interface wlan0mon
        ifindex 4
        wdev 0x2
        addr 4c:bb:58:0f:ba:aa
        type managed

Does anyone have a clue? thank you

edit solved with this trick! : Edit NewtorkManager.conf to prevent conflicts with airmon-ng (no check kill)

  • Don't add "solved" into the title ;) – A.B. Sep 19 '15 at 14:53
  • Sorry for that... That what we do in other forums... You should consider it; it is not a bad system ;) – kcdtv Sep 21 '15 at 23:59
3

I finally found a nice trick to have airmon-ng working as it is supposed to; without any need to "check kill" or turn off completely network manager. By the way It is network manager that is the cause of the problem since the version 0.9.8.10.

1. Open your network manager configuration file as root in order to edit it

sudo gedit /etc/NetworkManager/NetworkManager.conf

2. Add the following lines to prevent network manager from interfering with airmon-ng

[keyfile]
unmanaged-devices=interface-name:wlan0mon;interface-name:wlan1mon;interface-name:wlan2mon;interface-name:wlan3mon;interface-name:wlan4mon;interface-name:wlan5mon;interface-name:wlan6mon;interface-name:wlan7mon;interface-name:wlan8mon;interface-name:wlan9mon;interface-name:wlan10mon;interface-name:wlan11mon;interface-name:wlan12mon    #  avoid conflicts with airmon-ng

The wlanXmon interfaces are just for monitor mode... So there is no problems if network manager can't manage them : It shouldn't!
You can add as many interfaces as you want, 12 should be enough unless you are a addicted to buy wireless USB. Use the separator ; between every interfaces.

3. Saves the changes. Effects are immediate: you can now use mode monitor on one interface while you are connected to the Internet through network manager with another interface.

Solution previously published in aircrack-ng forum > Edit NewtorkManager.conf to prevent conflicts with airmon-ng (no check kill)

| improve this answer | |
0

Forget about airmon-ng script and try this:

sudo ifconfig wlan0 down
sudo iwconfig wlan0 mode monitor
sudo ifconfig wlan0 up

Now you can use airodump-ng with your interface in monitor mode:

sudo airodump-ng wlan0

Hope it helps. It worked for me!

| improve this answer | |
  • Thanks for your answer :) When I say in my post " (...) the only walk around i found is to bring down the interface and activate mode monitor with iwconfig Which does not satisfy me. " I was exactly referring to the solution you gently gave :) For sure it works but I would like to get the airmon-ng working with a unique and 100% mode monitor interface. – kcdtv Aug 24 '15 at 21:59
0

You don't need to set the interface down.

Just follow these steps:

airmon-ng check kill
airmon-ng start <interface>
airodump-ng wlan0mon

More infos

| improve this answer | |
  • Thanks for answering I don't want to "check kill" with airmon-ng to still have one of my interface connected to the internet. And also to have network manager enabled. It was working like a charm untill 15.04 without any need to "check kill"... problem is coming from newest network manager. cheers – kcdtv Aug 24 '15 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.