2

I just upgraded Ubuntu from 14.10 to 15.04 and when I boot I now get a question before the login screen that asks me for my private key password. I didn't quite now what this password was so I've tried several different ones and after entering any value it goes away and I can login. What is the program asking me for a password?

enter image description here

  • Perhaps a screenshot of this would help us help you determine what the program is asking you for a password prior to the login screen. Please take one, upload the image to a hosting service like imgur.com and edit your question to include the link. Have you tried storing the password for your network login? – Elder Geek Apr 27 '15 at 13:22
  • The only reference to this text I could find is with OpenVPN: gist.github.com/jaytaylor/1337457 and a bug report: bugs.launchpad.net/ubuntu/+source/openvpn/+bug/1374782 See #7. Please add yourself to the affected people. It has a "high" status so the more people are affected ... – Rinzwind Apr 28 '15 at 7:19
1

Workaround from the bug report. #5:

I use it as Client and have deactivated autostart AUTOSTART="none"

I start it manually, when i need the VPN. In prevuse version, the startscript asked for the password.

Regards Franz

So disable the autostart option in the openvpn config file (/etc/default/openvpn) and it will ask for it when you start it manually.


Another method from comment #8

I ended up rebuilding from source with --enable-systemd=no; that made it work again.


And you can also reboot into Grub and pick the "upstart" option so you revert back to the old method instead of using systemd.

  • @hiflyer if I was you I would remove the 2nd part, make a new question so people can focus on that and accept this one for the part that got answered (that is the way AU works best). – Rinzwind Apr 28 '15 at 8:26
  • I set AUTOSTART="none" and that removes the prompt. Thanks! – hiflyer Apr 28 '15 at 8:36
  • I moved the second part to a separate issue askubuntu.com/questions/615320/… – hiflyer Apr 28 '15 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.