I am trying to get rid of my Gnome panels so that I can go to a purely Docky/Gnome-Do environment.

I have got rid of everything, except for a single remaining panel which I cannot delete.

The text "Delete this panel" is greyed out - any pointers about how to get rid of it?


I haven't used gnome for a while, but I used to do that with gconf-editor.

Open "desktop >> gnome >> session >> required_components", then double-click the "panel" option, then remove the "gnome-panel" value and close it, then just:

killall gnome-panel

Last time I used this method was with Karmic tho.

  • 1
    This works fine in 10.10.
    – ændrük
    Oct 11 '10 at 21:44
  • 9
    One could argue you should change this to whatever docky needs to launch.
    – Oli
    Oct 11 '10 at 22:23

What I like to do is make the GNOME panel part of the Compiz widget layer. That way I can quickly pull up the panel with a hotkey in case I ever need it.

In CompizConfig Settings Manager, set Desktop -> Widget Layer -> Behavior -> Widget Windows to class=Gnome-panel. Fine-tune the other Widget Layer settings to your preference.

  • 1
    I like the elegance of this. Having a tried-and-tested fallback is handy when things break.
    – Oli
    Oct 11 '10 at 22:24

This also works with Natty Narwhal 11.04.

Open terminal and type

rm ~/.gconf/apps/panel/general/%gconf.xml.


My answer here may help. I figure you can likely do the same with docky that you do with AWN.

gconftool-2 --type=string --set /desktop/gnome/session/required_components/panel 'docky'

i solve it by just uninstalling and re-installing compiz manager.

  • Can you edit this answer to provide detailed instructions for how you do this? Sep 8 '12 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.