2

I have lenovo y510p with nvidia optimus(one intel hd 4600 and one gtx755m). i have fresh install kubuntu 15.04 and i can't get bumblebee work... Always finish with black screen and formatting the hdd. I use this guide: http://rajat-osgyan.blogspot.com/2015/03/how-to-install-bumblebee-on-ubuntu.html

But command primusrun glxinfo | grep OpenGL always return error. I try it 15+ time, but still can't make it work. Do you have a other good tutorial, how to do it. I use linux from 2 years as my workstation, but in home i'm still on windows and i wanna change that.

1

First undo everything that you did from the guide you linked to in your question, including uninstalling all the packages that you installed by following the guide and undoing the edits to files that you edited. Uninstall the Nvidia proprietary graphics driver and reboot the computer.

Open the terminal and type:

sudo apt install nvidia-346 nvidia-settings nvidia-prime
sudo reboot  

Nvidia Prime is a more up to date replacement for Bumblebee. Using Nvidia graphics drivers with initial Optimus support in Ubuntu is easier with Nvidia Prime. Nvidia Prime is not supported on some older models of laptops, however it is supported on the Lenovo IdeaPad Y510p laptop.

After the computer reboots, you will be able to switch between NVIDIA (Performance Mode) and Intel (Power Saving Mode) graphics from the NVIDIA Settings utility.

  • I have fresh install, so i don't have to remove anything. Thank you a lot! I'll try this later, when i come back home. – chilltouch Apr 27 '15 at 9:49
  • 1
    I'm glad to know that because installing Bumblebee by following the guide that you linked to in your question is a long, complicated procedure, and it would have taken a long time to undo all of the steps in the guide. – karel Apr 27 '15 at 9:53
  • Didn't worked for me with a Dell Vostro 5470 and a GeForce GT740M. Got gnome 3.16 crashing on boot: [ 9.916090] gnome-shell[1300]: segfault at 14 ip 00007feef5b5cad2 sp 00007ffd4a3a2690 error 4 in libmutter.so.0.0.0[7feef5b26000+e4000] – fanl May 14 '15 at 0:47
  • It could be because gnome-shell 3.16 is not the stock GNOME shell for 15.04. You could try going back to the default GNOME shell from the default Ubuntu repositories. Since you didn't install GNOME shell from the default Ubuntu repositories, check the instructions that you followed to make sure that you didn't make a mistake when installing it. – karel May 15 '15 at 2:52
  • nvidia-prime doesn't work for me, it's full of bugs and everything gets messed up when I switch profiles. Bumblebee doesn't work either, no matter what I do. My notebook is a Dell Inspiron 14R 5421 and I couldn't properly use linux so far after buying it. – renatov May 18 '15 at 23:45
0

This worked for me:

sudo apt-get install nvidia-346 nvidia-settings nvidia-prime
sudo reboot
0

I somehow had 2 bbswitch versions installed at the same time even affter purging all nvidia packages. You can check this with dkms status and do an apt-get purge bbswitch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.