2

When I was upgrading from 14.10 to 15.04 my mysql somehow broke.

When I run

sudo dpkg --configure -a

After a long wait I get the following response

Setting up mysql-server-5.6 (5.6.24-0ubuntu2) ...
Job for mysql.service failed. See "systemctl status mysql.service" and                     "journalctl -xe" for details.
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.6 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.6; however:
Package mysql-server-5.6 is not configured yet.

dpkg: error processing package mysql-server (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mysql-server-5.6
mysql-server

can anyone tell me how to resolve this issue?

Many thanks.

2

Ok so after much help from @kos and google I have managed to get it sorted.

The steps that seemed to work were as follows.

sudo apt-get remove --purge mysql-server mysql-client mysql-common
sudo apt-get autoremove
sudo apt-get autoclean

Then I ran

tasksel

And ticked the lamp option. For some reason this angle worked. Though I cannot tell you why.

0

One way would be to remove MySQL and re-install it:

sudo apt-get purge mysql
sudo apt-get install mysql

If you want you can backup everything first:

/usr/sbin/service mysql stop
cp -rf /var/lib/mysql/* "~/BACKUPS/MySQL/"
/usr/sbin/service mysql start
1
  • FYI, there is no suck package as mysql. What you meant is probably mysql-server. – Andrejs Cainikovs Jun 30 '15 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.