7

I updated to Ubuntu 15.04 and now my swap partition does not seem to mount. I'm not an expert, but it looks like the partition does not seem to have a UUID anymore. How do I get the swap partition to activate again?

sudo journalctl -b | grep swap
Apr 26 21:21:13 MacBook systemd[1]: Activating swap Swap Partition...
Apr 26 21:21:13 MacBook swapon[355]: swapon: /dev/sda5: read swap header failed
Apr 26 21:21:13 MacBook systemd[1]: dev-sda5.swap swap process exited, code=exited status=255
Apr 26 21:21:13 MacBook systemd[1]: Failed to activate swap Swap Partition.
Apr 26 21:21:13 MacBook systemd[1]: Unit dev-sda5.swap entered failed state.
Apr 26 21:22:41 MacBook systemd[1]: Job swap.target/start failed with result 'dependency'.
Apr 26 21:22:41 MacBook systemd[1]: Job dev-disk-by\x2duuid-3e396c03\x2d9185\x2d47b6\x2d9f68\x2d3450be86289f.swap/start failed with result 'dependency'.
Apr 26 21:24:12 MacBook systemd[1]: Job dev-disk-by\x2duuid-3e396c03\x2d9185\x2d47b6\x2d9f68\x2d3450be86289f.swap/start failed with result 'dependency'.

cat /etc/fstab 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=f25d1301-fc5c-4f42-862b-c0097261522c /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=3e396c03-9185-47b6-9f68-3450be86289f none            swap    sw              0       0

lsblk -f
NAME   FSTYPE  LABEL        UUID                                 MOUNTPOINT
sda                                                              
├─sda1 vfat    EFI          2860-11F4                            
├─sda2 hfsplus Macintosh HD 6c563b0e-e711-3a7a-8ac8-3baedccb3282 
├─sda3 ext3                 f25d1301-fc5c-4f42-862b-c0097261522c /
├─sda4 ntfs    WinXP        36202C2F202BF511                     
└─sda5                                                           
sr0                          
15

Seems like your swap partition is wrongly or not formatted. (Or got damaged somehow)

Reformat sda5 as SWAP (using GParted, parted or fdisk) and make sure the UUID in fstab matches the one from sudo blkid.

Then run sudo swapon /dev/sda5 to enable swapping to this partition, if you don't want to reboot.

  • You beat me to it! Great answer! +1 – Terrance Apr 26 '15 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.