I have updated my kubuntu 14.10 to kubuntu 15.04. And now after boot, when I enter my password on welcome screen, I will get black screen. It's looks like screen powered off. No cursor, no change brightness. Nothing. And when I try switch to text consoles (Ctrl+Alt+F1) nothing happening. If I doesn't login in welcome screen I can switch to text console.

  • Are you using any proprietary drivers like catalyst or nvidia? If so, have you tried removing them? Also, try making a new user and see if logging into it works. – Paul Tanzini Apr 26 '15 at 19:19
  • My notebook have only intel graphics. No proprietary drivers i've installed. But on desktop, when I have proprietary NVIDIA drivers all fine! With new user will try. Thank you! – Максим Т Apr 27 '15 at 9:10
  • I've had the same problem. I did new instalation and I've got the same.I repeated once again, but I didn't check my old /home folder to add during instalation by mistake.Now my kubuntu 15.04 works correktly. Probably old configuration in hidden files in /home folder make error. – user402397 Apr 27 '15 at 16:05
  • It's interested. When you did new installation the first time did you set your old home directory? – Максим Т Apr 27 '15 at 19:18
  • @Максим Т: Do you see an empty task bar (which disapear) at the black screen ? – Guillaume May 1 '15 at 18:22

I may have a solution, I've been trying to figure out what happened for a few days now. Deleting all ~/.cache and ~/.config is not a great idea, as those could be needed but. . .

In ~/.cache, I have deleted only the files with a 14.04 boot DVD, but I have kept the folders:

motd.legal-displayed (0 kb)

After rebooting, the desktop was fine.

  • Thanx, will try. – Максим Т May 5 '15 at 10:44
  • 1
    But after some time it happened again. :( – Максим Т May 6 '15 at 8:54
  • 1
    you should verify if your graphic driver is good for your card – Guillaume May 6 '15 at 10:35

I ended up having to rename ~/.kde, ~/.cache ~/.local and ~/.config.

mv ~/.kde ~/.kde.old
mv ~/.cache ~/.cache.old
mv ~/.local ~/.local.old
mv ~/.config ~/.config.old
shutdown -r now

Not sure exactly which one did the trick but I suspect it was .config.

  • Wow. How many directories. :) Thanx. Renaming .kde and .cache didn't help. – Максим Т Apr 29 '15 at 11:45
  • Didn't help. :( I think something with power management. After password entry monitor switching off... – Максим Т Apr 30 '15 at 13:09
  • 2
    This is pretty overkill. .kde and .config store a lot of useful stuff. FWIW, I solved my problem just by moving .local. Then it's pretty easy to check back through you old .local/share/ to see if there's any data that you might want to migrate back (e.g. tomboy stores notes there). – naught101 Dec 2 '15 at 23:20

This has troubled me for some time now. I noticed it happens when I put Kubuntu to sleep or shut it down with a dual monitor set-up and then trying to start it with the laptop screen only. Anyway, here's what I found - one particular folder is responsible for this mess. Deleting it fixes my problem.

Here's what to do. Once you get the black screen go to a tty (Ctrl+Alt+F1) and do the following:

 rm ~/.local/share/kscreen
 sudo killall sddm

Then enter your password and login. Everything should be ok. Hope this helps ;)

  • Thanx, but unfortunately I have setup system from scratch. Now it's works. :) – Максим Т Feb 3 '16 at 19:42
  • I had exactly the same problem and this fixed it. Thanks – Rembunator Sep 9 '16 at 6:43

I too had the same problem in the fresh install of kubuntu 15.04 64 bit.

  1. Press Ctrl+Alt+F1 after the system has started
  2. System will prompt to login give your login name and press enter
  3. Enter the password

    mv ~/.kde ~/.kde.old
    mv ~/.cache ~/.cache.old
    shutdown -r now
  4. If you can get your gui on next boot don't forget to change 'start with empty session' in 'desktop session' in 'System Settings'

  • Thanx! I haven't thought about cache. Will try. – Максим Т Apr 28 '15 at 15:52
  • Didn't helped. :( – Максим Т May 5 '15 at 10:41
  • this worked for me, thanks :) (kubuntu 15) – MilMike Sep 22 '15 at 10:45

I had the same issue; the problem was I had two different versions of the nvidia drivers installed. Looks like the dist-upgrade automatically installed nvidia-340, so just run the command below then restart and you should be good.

sudo apt-get purge nvidia-340*
  • As i mentioned I haven't nvidia adapter in my notebook. :) – Максим Т Apr 28 '15 at 11:10

I have the same problem. After going through few blogs and forums I came across solution but it didn't work for me. It's worth trying following commands and see if it solves your problem.

mv ~/.kde ~/.kde.old
shutdown -r now

  • I've tried this. Doesn't work. :( – Максим Т Apr 27 '15 at 8:19
  • Create a new user and give a try. It worked for me. – Jhones Apr 30 '15 at 9:00
  • I've tried. Doesn't work. – Максим Т May 5 '15 at 10:42

Following steps worked for me.

  1. From the grub menu select "system settings" which will put you to the bios menu.
  2. View boot order (no changes are required).
  3. Save change and exit.

Boot after steps 1-3 prevents blank screen. I do not know how but it worked for me well.


So I faced this issue after changing my user password, and was only able to solve this after changing it back to the old one via 'passwd' command.


TL;DR: Check if you have sufficient space in /var, /, /home. Insufficient space prevents xOrg server to start.

To get the system back, you can run startx in the terminal, which should give you some hints, as indicated by this reddit thread. This command starts the xOrg server. The proposed solution in the reddit thread with changing ~/.xinitrc didn't work for me.

If startx did indeed get your system back, you could reboot, back into the terminal and look if the xserver isn't running by running xset q as indicated here. Since echo $DISPLAY didn't return anything for me, I found these solutions, as startkde didn't work either (startkde would start the kde session). Most importantly, /var, /, /home should have enough space (check disk usage with df -h).

These solutions finally proved to be worthy, as I simply had no space left. After cleaning up some files and rebooting, KDE did start as usual.

Not the answer you're looking for? Browse other questions tagged or ask your own question.