5

How do you fix being unable to login to Gnome-Shell?

I upgraded to 14.04 from 12.04 on a Macbook, and after some initial trouble configuring video, I was finally able to get the Nvidia driver to work and login as normal. My system was running fine for several weeks until after a routine package update that didn't require a reboot, when I suddenly became unable to login to Gnome-Shell. I only discovered the problem when I did Alt+F2 and entered "r" to reload Gnome-Shell to test how much memory would be freed up.

Instead of reloading all the windows on my desktop, it closed everything and kicked me back to the lightdm login screen. From there, trying to login just makes the screen flicker, briefly shows me the Nvidia logo, then kicks me back to the login screen.

I've tried all the solutions mentioned here, for similar problems logging in, including:

  • deleting my ~/.Xauthority file and rebooting
  • reinstalling the ubuntu-desktop package and rebooting
  • ensuring everyone has access to write to /tmp
  • ensure all files in ~ are owned by me
  • checking ~/.xsession-errors for explanation (nothing's listed)
  • checking my ~/.bashrc, ~/.profile and ~/.bash_aliases files for any strange commands that might be erroring out. I haven't changed these between when I could login and when the problem started.
  • running sudo dpkg-reconfigure lightdm and rebooting
  • running sudo dpkg-reconfigure gdm and rebooting. I don't even get a login screen after that.
  • check /var/log/Xorg.0.log for errors. I found none.
  • check /var/log/lightdm/lightdm.log for errors. I found none.

None of these worked for me.

The only thing I discovered that worked was I can successfully login as myself into Unity. I can also login to Unity as guest, although neither a brand-new user nor guest can login to Gnome-Shell.

So it definitely seems to be a Gnome-Shell issue, but I'm not seeing any explicit errors that would tell me what's wrong. What's really strange is I haven't changed or installed anything new that would have make this break all of a sudden. How do I diagnose this?

I only have two shell extensions installed, system-monitor and alt-tab, but they've been there for weeks without issue. What would be stopping me from logging in to Gnome-Shell?

My installed graphics packages reported by dpkg --get-selections |grep -v deinstall|grep -i nvidia are:

nvidia-340                  install
nvidia-340-uvm                  install
nvidia-opencl-icd-340               install
nvidia-prime                    install
nvidia-settings                 install

closed as off-topic by muru, Eric Carvalho, Maythux, Fabby, Seth May 16 '15 at 1:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – muru, Eric Carvalho, Maythux, Fabby, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you make a new user and see if you can log into gnome there? Also, what graphics are you using, and do you know which package update caused this? – Wilf Apr 26 '15 at 17:23
  • @Wilf, Neither a new user nor guest can login to gnome-shell either. Unfortunately, I don't remember what packages were updated. I gave the list a quick glance, and none of them seemed critical, which is why I didn't bother remembering them. I would have taken note if the kernel or nvidia driver was being updated. – Cerin Apr 26 '15 at 17:29
  • @Wilf, Also, I've updated my question with a list of my graphics packages. – Cerin Apr 26 '15 at 17:33
  • Change the standard session with sudo /usr/lib/lightdm/lightdm-set-defaults --session gnome-shell and run `startx in TTY1. What happens? – A.B. May 11 '15 at 13:40
0

Unfortunately, as mysteriously as the problem began, so did it end. I was forced to use Unity for a couple weeks, performed a few standard updates with apt-get, and then when I tested gnome-shell again, it worked.

Not the answer you're looking for? Browse other questions tagged or ask your own question.