0

After downloading steam, it requires me to download the packages libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, and libc6:i386. However, when I attempt do do so I get this error message:

E: unable to locate package libl1-mesa-dri:i386
E: unable to locate package libgl1-mesa-glx:i386
E: unable to locate package libc6:i386

How can I download them?

0

Instead of downloading Steam, open a terminal window (Ctrl + Alt + T) and type:

sudo apt-get remove --purge steam

Press ENTER. Your password will be requested, type it and press ENTER again. This command will remove Steam if it was installed with errors.

Then type:

sudo apt-get install steam

And press ENTER. Wait for the process to end, and steam will be installed on your computer, including all of the needed packages.

Note: I am posting this answer assuming that you downloaded Steam directly from your browser.

EDIT: If everything works, a Steam Launcher should appear in your Desktop. If this does not happen, open a terminal window and type

steam

And then press ENTER. Also, if you really want to install those packages, remove that :i386. For example, instead of sudo apt-get install libgl1-mesa-dri:i386 use sudo apt-get install libgl1-mesa-dri. Seems that i386 only indicates that you need a 32-bit package.

  • I still get the same error... – Juan Pardo Apr 26 '15 at 21:10
  • even if you try installing all the packages without :i386? – Eduardo Cola Apr 26 '15 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.