3

I installed Lubuntu 15.04 and everything is working fine except one annoying feature: battery information is not shown any more.

In Lubuntu 14.10 the indicator is available: http://i.stack.imgur.com/kb2uG.png

But in Lubuntu 15.04 battery indicator is missing: http://i.stack.imgur.com/PGQPm.png

I have now installed two computers with Lubuntu 15.04:

  1. 32-bit OS using Software Updater

  2. 64-bit OS from scratch

Both of them (and also live session) is not showing the battery info.

Any ideas?

5

Right-click the Taskbar > Add/remove items from the panel > Add

and then look for battery items.

Note: Sorry if the items above do not have these exact names, but it should be something like these (I am using a Portuguese Lubuntu 15.04 version).

3
  • Thanks Eduardo. I checked my Lubuntu 14.10 computer and there I found "Power Manager Plugin" available to be added as panel applet. But the applet is not available in Lubuntu 15.04. – Unto Apr 26 '15 at 18:50
  • Oh, actually I am using Ubuntu 15.04 with LXDE installed, maybe that is the point... – Eduardo Cola Apr 26 '15 at 19:00
  • The required panel item is called "Battery Monitor" under Lubuntu 15.10. After adding it, double-click it in the list of existing panel items and enable "Show Extended Information". It will show current laod, remaining capacity etc. when mousing over the panel icon. Can make switching xfce4-power-manager unnecessary for some. – tanius Feb 24 '16 at 12:10
1

One way to get a battery indicator icon is to use the one fromxfce4-power-manager. Obviously, this involves configuring Lubunu's LXDE to use this power manager, which is normally meant for the XFCE desktop environment:

  1. Install required packages:

    sudo apt-get install lxsession-default-apps xfce4-power-manager
    
  2. Go to "Menu → Preferences → Default application for LXSession" (or start lxsession-default-apps) and set both "Core applications → Power Manager" and "Core applications → Lock Screen Manager" to xfce4-power-manager.

  3. Go to "Menu → Preferences → Power Manager" (or start xfce4-power-manager-settings) and enable "General → Appearance → Show system tray icon".

  4. The XFCE battery indicator we want is a system tray icon, not a panel item by itself. So right-click on the LXPanel, choose "Add / Remove Panel Items" and make sure you have "System Tray" in the list. If not, add it.

You should have a battery indicator icon now. A logout / login cycle may be required though. For more details and troubleshooting refer to this answer. Mine is a tidied-up version of that.

0

Just install batmon.app by terminal:

sudo apt-get update
sudo apt-get install batmon.app

Or using Lubuntu Software Center

1
  • Works under Lubuntu 15.10 in the sense it installs (~15 MiB of stuff) and can be started manually. But how to integrate it as an indicator in LXPanel, I don't know. – tanius Feb 24 '16 at 12:04
0

im new in lubuntu. Im running 16.04 LTS lubuntu, and i've the same problem with you. To make the battery icon apear again on your lxpanel, all you need is to set it up on:

Menu Button (by default is on the corner of left-bottom) -> Preferences -> Power Manager -> Check the 'Show system tray icon'.

Done! Your battery icon should appear now.

It works for me. Hope it works for you too!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.