1

I have a fresh install of Kubuntu 15.04. Before installing 15.04 I used Ubuntu 14.10 with the latest NVIDIA drivers. With that version I had no problems with the graphic card (screen resolution). Btw. my PC contains a GeForce (GF104) GTX 460.

As far as I know the default installation of Kubuntu uses the NOUVEAU driver. I selected the driver 346.59 provided in System Settings -> Driver Manager to switch to NVIDIA. (I even tried the older versions)

After a reboot I had a very bad screen resolution. I checked the settings inside "NVIDIA X Server Settings". There I have seen that the current resolution is: 1920 x 1080, which was not correct. The resolution looked like 640x480 or sth. like that.

Even the "Display Configuration" of Kubuntu showed me that value. I tried to blacklist NOUVEAU but it didn't change anything. Even the "boot screen" of Kubuntu disappeared after switching to NVIDIA.

So what am I doing wrong?

Thanks!

Update: This is what I get after booting with NVIDIA driver.

dmesg | grep nvidia
[    6.700837] nvidia: module license 'NVIDIA' taints kernel.
[    6.714403] nvidia: module verification failed: signature and/or  required key missing - tainting kernel
[    6.719445] [drm] Initialized nvidia-drm 0.0.0 20140818 for 0000:03:00.0 on minor 0
  • How about after sudo dkms autoinstall? – Karl Richter Apr 26 '15 at 13:11
2

I solved my problem! First I removed the existing NOUVEAU.

sudo apt-get --purge remove xserver-xorg-video-nouveau

With sudo nvidia-xconfig I created a new xorg.conf

After that I added the DPI line.

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    Option         "DPI" "86 x 86"
EndSection
  • I have the nvidia driver and not nouveau. But bbswitch seems to be causing the problem when I see the output of dmesg. – leastaction Jun 9 '15 at 18:33
  • My above solution fixed the bad resolution / bad DPI setting. The above messages still appears in dmesg. – Ferhat Jun 10 '15 at 19:29
  • Does the mouse pointer and system still freeze for a few seconds every 5 to 10 seconds while using it? – leastaction Jun 14 '15 at 13:29
  • There is no monitor section in the xorg.conf that was created by my nvidia-xconfig. – leastaction Jul 12 '15 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.