5

Everything else regarding audio, HDMI (video) ja the video card works, except seemingly not randomly the audio skips if I direct it over HDMI to my TV. And by seemingly not randomly it is very reproducible, though I cannot tell what exactly triggers it.

Things that trigger a skip are definitely things like Variety changing the desktop wallpaper. This happens just about every time, causing 1-2 skips (each skip is under a second). Lots of typing (like I am doing now, causes skips every sentence or so). Lots of web page scrolling seems to trigger quite a bit of skipping too.

I thought at first it was disk activity, but it is not - for example opening a 200mb bz2 file doesn't cause a skip at all. Also, not doing anything, causes no skips, if I turn off Variety and don't do anything, I get perfect no skipping audio (streaming video or watching an AVI for example).

If the computer is busy, like after boot, the audio is very crackly at first, skipping more than playing. Once things settle down, skipping becomes only intermittent.

The computer is not out of resources and skipping happens even with a few programs open.

An insanely annoying problem which I've tried many ways to tackle, including;

  • newer kernel
  • newer HDMI drivers (via xedgers)
  • various audio debugging tips from community help

When I use HDMI audio, I usually have a dual monitor setup. The audio is directed to HDMI, but mostly I use a monitor. I have however tried using only the HDMI TV as a monitor - skipping still happens without a dual monitor setup. When using attached speakers via the built in sound card, there are no problems.

My Alsa information output is here: http://pastebin.com/0jPHeYFt

Other stats:

  • alsa-base 1.0.25+dfsg-0ubuntu4
  • nvidia-304 304.125-0ubuntu0.1 (tried xedgers 340 I think with no better perf)
  • pulseaudio 1:4.0-0ubuntu22
  • Ubuntu 14.10 3.18.9-031809-generic

Motherboard is an Asus Z97-AR, BIOS American Megatrends Inc. 1304. NVIDIA card is GeForce GTX 760

       *-display
            description: VGA compatible controller
            product: GK104 [GeForce GTX 760]
            vendor: NVIDIA Corporation
            physical id: 0
            bus info: pci@0000:01:00.0
            version: a1
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
            configuration: driver=nvidia latency=0
            resources: irq:16 memory:de000000-deffffff memory:d0000000-d7ffffff memory:d8000000-d9ffffff ioport:e000(size=128) memory:df000000-df07ffff
       *-multimedia
            description: Audio device
            product: GK104 HDMI Audio Controller
            vendor: NVIDIA Corporation
            physical id: 0.1
            bus info: pci@0000:01:00.1
            version: a1
            width: 32 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list
            configuration: driver=snd_hda_intel latency=0
            resources: irq:17 memory:df080000-df083fff

Any tips on what to try and how to debug this more?


Edit 26th Nov '15. I've upgraded my BIOS to the newest version, which seemed to help a lot. There is still some skipping however, but at least this suggests problems with the Asus motherboard. On some forum thread I found a similarly sounding problem relating to pci related stuff, which got me to upgrade the BIOS version. I'll see next what the NVIDIA latest driver does, though it is only a minor upgrade from 352. I'll also try the /etc/pulse/default.pa edit as suggested in comments.

  • 1
    Did you tried edit pulse default? sudo nano /etc/pulse/default.pa. and replace load-module module-udev-detect to ` load-module module-udev-detect tsched=0 ` and save file. – Marcos Silveira Nov 23 '15 at 18:33
  • Take a look at this answer. It has been answered before. – adeen-s Nov 27 '15 at 9:11
  • @adeen-s - there is no answer there, just an open question. Audio jack works fine - but that is not a solution, only a workaround. – jaywink Nov 27 '15 at 9:48
  • @MarcosRocha - awesome, that actually fixed the last skipping! I changed it, booted, started music via Clementine immediately after boot (which itself skips for a while) - then fired browser with lots of tabs, youtube videos, digikam, pycharm - all the heavy stuff. Clementine plays without skipping happily! Thanks! Could you answer the question with your solution so I can mark it as accepted and make sure you get the bounty (will recreate if it runs out)? – jaywink Nov 28 '15 at 10:21
  • @jaywink - I'm too glad to help. I answered your question below as you solicited. – Marcos Silveira Nov 30 '15 at 22:47
4
+200

Open a terminal (CTRL+ALT+T)

Edit the pulse audio default files:

sudo nano /etc/pulse/default.pa

Replace load-module module-udev-detect to load-module module-udev-detect tsched=0, save file and reboot.

Good luck.

  • 1
    Bummer, needed to double the bounty :D But really happy to have gotten the HDMI sound working, thanks for that. Well worth the 200 coming up in 23 hours :) – jaywink Dec 1 '15 at 19:40
  • Odd, after waking from a suspend sound is even more flaky :) But after reboot everything works as it should. – jaywink Dec 5 '15 at 15:42
0
+50

You are having very 'outdated' video drivers installed on your computer.
NVIDIA improved their drivers a lot since the release of 304 GPU drivers.
You should use the latest official drivers that support GEFORCE GTX760.

Uninstall every NVIDIA software by executing:

sudo apt-get purge nvidia*
sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa
sudo reboot

Now reinstall the NVIDIA drivers by executing:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358
sudo reboot 
  • Unfortunately as said in the question, I tried at the time newer 340 without any difference. Right now I'm running 352. I will try the latest drivers but so far, any driver version has made no difference to the skipping of the sound. – jaywink Nov 26 '15 at 20:35
  • @jaywink : As you said that you are using Ubuntu 14.10 ... (not supported anymore) ... you should install Ubuntu 15.10 with kernel 4.2 and then install the drivers following the instruction given in my answer. :) – cl-netbox Nov 27 '15 at 11:21
  • Actually I'm running 15.04 these days, need to upgrade the question. Kernel is stuck at 3.18, can't upgrade past that due to some other issue with boot getting stuck after grub. Removing NVIDIA drivers doesn't help for that. Maybe I need to reinstall the whole damn thing. I'm just not so sure this is an Ubuntu problem, after upgrading BIOS helped so much. – jaywink Nov 27 '15 at 20:32
  • Btw, upgraded to 358 according to the PPA, thanks for that! But it didn't change anything, still some skipping, though a lot less due to BIOS upgrade earlier. – jaywink Nov 27 '15 at 20:34
  • @jaywink : Having read your comments ... you definitely should install the current edition Ubuntu 15.10 (15.04 support ends soon) and then install the NVIDIA drivers ! I am sure after that the problems will be gone. :) – cl-netbox Nov 28 '15 at 8:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.