1

As opposed to this question, I'd like to change the window manager that unity-2d launches when logging in. IOW, when I select a "Unity 2d" session at the greeter screen and log in, I want to change things such that a different window manager is launched instead of metacity.

Neither setting the:

/desktop/gnome/applications/window_manager/default

nor the

/desktop/gnome/session/required_components/windowmanager

gconf keys seems to make a difference.
How can this be done? I'm running Ubuntu 11.04.

$ apt-cache policy unity-2d
unity-2d:
  Installed: 3.8.4.1-0ubuntu1
  Candidate: 3.8.4.1-0ubuntu1
  Version table:
 *** 3.8.4.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
2
  • I'm not clear on what you are asking as distinct from the other question. (Perhaps if the answer in the other was elaborated, I would see this more easily....)
    – belacqua
    Sep 14, 2011 at 16:56
  • Not sure how to make it clearer. I elaborated in the question. Perhaps if you told me what was unclear about the question... Sep 14, 2011 at 17:04

1 Answer 1

5

Unity 2D is largely window-manager independent. However the Unity 2D session defines metacity as the window-manager and ignores the relevant gconf keys you listed.

If you look in /usr/share/gnome-session/sessions you will see the different sessions defined for the benefit of gnome-session.

You can create a new session. For example, here is mine, called 2d-ubuntu-compiz.session:

[GNOME Session]
Name=Unity 2D with Compiz
Required=windowmanager;panel;filemanager;
Required-windowmanager=compiz
Required-panel=unity-2d-panel
Required-filemanager=nautilus
DefaultApps=gnome-settings-daemon;unity-2d-launcher;
FallbackSession=classic-gnome

You could also change the line to Required-windowmanager=gnome-wm

which should then respect the gconf keys for the window manager.

Then all you need is to tell the logon manager (gdm) about your new session. Create a new file in /usr/share/xsessions. Here is mine, called unity-2D-compiz.desktop

[Desktop Entry]
Name=Unity 2D with Compiz
Comment=This session logs you into Unity 2D
Exec=gnome-session --session=2d-ubuntu-compiz
TryExec=gnome-session
Icon=
Type=Application
X-Ubuntu-Gettext-Domain=unity-2d

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .