8

This question already has an answer here:

VLC was working fine until I upgraded to 15.04. When I try to install via Software Centre, I get this error message:

The following packages have unmet dependencies:

 vlc: Depends: vlc-nox (= 2.2.0-1) but 2.2.0+ppa2.4 is to be installed
 Depends: libavcodec-extra-56 (>= 6:11.2) but 6:11.2-1 is to be installed
 Depends: libavutil54 (>= 6:11~beta1) but 6:11.2-1 is to be installed
 Depends: libc6 (>= 2.16) but 2.21-0ubuntu4 is to be installed
 Depends: libegl1-x11 but it is a virtual package
 Depends: libfreetype6 (>= 2.2.1) but 2.5.2-2ubuntu3 is to be installed
 Depends: libgcc1 (>= 1:4.1.1) but 1:5.1~rc1-0ubuntu1 is to be installed
 Depends: libgles1 but it is a virtual package
 Depends: libgles2 but it is a virtual package
 Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 is to be installed
 Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 is to be installed
 Depends: libstdc++6 (>= 4.9) but 4.9.2-10ubuntu13 is to be installed
 Depends: zlib1g (>= 1:1.2.3.3) but 1:1.2.8.dfsg-2ubuntu1 is to be installed

And via Terminal:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.0-1) but 2.2.0+ppa2.4 is to be installed
       Recommends: vlc-plugin-notify (= 2.2.0-1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.0-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I do dpkg --get-selections | grep hold it appears that no packages are being held

When I do dpkg --get-selections | grep vlc it shows this:

libvlc5                     install
libvlccore8                 install
vlc-data                    install
vlc-nox                     install

Also when I try to remove it via Terminal it says it is not installed and therefore cannot be removed. I have also tried the daily release videolan ppa with the same unfortunate results. How can I get my good old VLC back? Thanks for your help!

marked as duplicate by David Foerster, chaos, Maythux, Eric Carvalho, Warren Hill Apr 29 '15 at 12:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What software sources are enabled? Also try run sudo apt-get update after you add the vlc ppa – user371765 Apr 26 '15 at 7:04
  • Post the output of apt-cache policy vlc in your question. – A.B. Apr 26 '15 at 8:41
10

The problem seems to be in vlc-nox, that is not removed when Ubuntu is upgraded. If you remove it at first, everything should work OK. Something like that:

sudo apt-get remove vlc-nox
sudo apt-get autoremove
sudo apt-get update

And then install vlc (3.0 worked for me):

sudo add-apt-repository ppa:videolan/master-daily
sudo apt-get update
sudo apt-get install vlc

That should make it work. This PPA contains daily changing, potentially unstable or broken development builds. See the PPA description:

This PPA contains daily builds from the VLC development branch.

Not the answer you're looking for? Browse other questions tagged or ask your own question.