3

Initially, clicking a magnet link would do nothing, but after some research, I ran the following command:

xdg-mime default deluge.desktop x-scheme-handler/magnet

Now, as the title says, clicking a magnet link will open Deluge, but it won't actually start the torrent.

I can't find any behavior similar to this and I'm stumped.

Any suggestions?

4
  • Maybe, setting "Add torrents in Paused state" is enabled? It's located in "Edit > Preferences > Downloads". – andrybak Apr 26 '15 at 5:50
  • @andrybak Nope, its disabled. It only launches the program as if I just clicked the Deluge launch icon. I still have to manually add the URL – travisw Apr 26 '15 at 6:36
  • Had the same problem .... been messing with "xdg-mime" and other suggested methods ... neither worked for me. When I open magnet from Firefox - easy peasy, but it doesn't work with Chrome – RiddleMeThis May 10 '15 at 11:38
  • Likely this bug: bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1453174 – Cas Jul 10 '16 at 11:14
4

When you click the magnet link and Deluge opens, does it actually add the torrent to the queue?

I currently have the issue where clicking a magnet link will open Deluge but will not add the torrent.

As a workaround, you should be able to right click on the magnet link and copy the link address, then in Deluge go to File > Add Torrent > URL

1

Non answer here, but I cant add a comment yet so adding this as an [non] answer.

For Chrome, it seems to run "xdg-open" when a magnet link is clicked with the magnet URL passed in as the $1 to the command. This does successfully trigger Deluge to open, but it fails to actually add the torrent.

It used to work just fine for me in 14.04 and I just recently took the dive and upgraded to 14.04 -> 14.10 -> 15.04 and now it's broken. So perhaps seeing that xdg-open is a rather simple wrapper to call Deluge, perhaps something changed with how deluge wants the magnet link passed to it from xdg-open?

Update: Looks like the culprit could be with gvfs-open, which is what apparently xdg-open calls. Looks like 1.22 worked, 1.24 doesn't.

0

I get a solution for same problem, You have to set Download location on Preferences> Downloads> Download to : add the valid path on text box and then Its working...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.