35

Upgraded 14.10 to 15.04, desktop fails to load past login screen. I type in my password, hear a failure sound byte, back to login screen. Also can't boot off a 15.04 thumb drive created with another PC. Guest account does same thing. Tried removing all nvidia driver packages, tried messing with .Xauthority, tried using gdm instead of lightdm (failed even worse: no login screen at all). Tried reinstalling ubuntu-desktop. Get error code of ACPI PCC probe failed, starting 219 or something like that.

Currently running 15.04 off said thumb drive...on an another PC with AMD integrated graphics, no issues.

15.04 doesn't like Nvidia graphics cards. Please help!

  • A similar question is askubuntu.com/questions/613577 . – JdeBP Apr 26 '15 at 6:34
  • have you tried creating a new user or starting with a clean home folder? – Giovanni Toraldo Apr 26 '15 at 13:40
  • I have tried creating a new user and the problem persists. Thanks for the response! – Dustin French Apr 26 '15 at 14:49
  • Are you installing the driver for CUDA or for visualization on your actual screen? If it's for CUDA make sure you don't install openGL in the cuda.run file. – user1282043 Sep 18 '15 at 6:09

12 Answers 12

17

it's you from the future. Here's how I fixed it: I didn't! I re-downloaded the 15.04 image from the Ubuntu website and created a startup "disk" on a USB thumb drive. Today it worked, wehereas it didn't last night :( Perhaps Canonical fixed their image... So I booted from the thumb drive and removed my existing 15.04 and installed a fresh copy! Sure I lost all of my files (VirtualBox, all installed games, etc.) but now Linux works again. Let this be a lesson to you Dustin! Never try and upgrade an Ubuntu OS! Just backup all of your files and do a clean install... just like you used to have to do with Windows!

  • Bump. I just lost my linux install after upgrading to 15 from 14. Black and grey screen loop even before I see login screen. Any way to fix it without fresh install? if i ctrl alt f1 it goes back to loop after 2 seconds of console.. – Zasz Jul 4 '15 at 14:41
  • Future Dustin, you're a goddamn genius. – Motoma Dec 18 '15 at 2:04
  • @zasz That just happened to me. A solution was to continue ctrl+alt+f1-ing and remove gdm. – Neal Mar 3 '16 at 18:14
  • @Neal, for the life of me i'll never understand gdm vs lightdm. i don't know what they are, i don't know which one i have, and i damn well know that my system won't run the other one (tried it). .......i guess what i'm trying to say is happy Friday! – Dustin French Mar 4 '16 at 18:43
12

I had the exact same problem. I'm not sure exactly why it happened, but it seems my kernel was not updated.

To solve that I used Ctrl+Alt+F1 to go to a text-based virtual console, logged on there, then ran:

sudo apt-get install linux-generic

Everything started working again.

9

My fix for my laptop

Dell xps l502x, so it is Intel + Nvidia optimus graphic card.

Have a look at what you have

dkms status

You may get something like this

bbswitch, 0.7, 3.19.0-15-generic, x86_64: installed
nvidia-340, 340.76, 3.19.0-15-generic, x86_64: installed

Remove all Nvidia drivers, make Ubuntu back to “clean” state.

Have a look at this: https://unix.stackexchange.com/questions/144871/remove-all-nvidia-files

Basically, you do:

sudo apt-get purge $(dpkg -l | awk '$2~/nvidia/ {print $2}')

This should remove all nvidia drivers and now you should be clean.

You may want to double check:

dkms status

Install Nvidia driver

Have a look at this: http://www.binarytides.com/install-nvidia-drivers-ubuntu-14-04/ (the command line part)

I tried to install nvidia-349, it didn’t work, then I remember previously I used nvidia-340. It seems important to remember what works for you. I do:

sudo apt-get install nvidia-340 #(you may want to try nvidia-346)

Look at this long guide

http://rajat-osgyan.blogspot.com.au/2015/03/how-to-install-bumblebee-on-ubuntu.html

On step 4, instead of

sudo echo ON > cat/proc/acpi/bbswitch 

I changed it to

sudo tee /proc/acpi/bbswitch <<<ON

based on https://github.com/Bumblebee-Project/bbswitch

Sometimes after turn on bbswitch, reboot, when I do echo /proc/acpi/bbswitch, I still see it OFF. Make sure Nvidia is installed in the first place or reboot for couple of times. If it is OFF, follow the guide to next step.

Reboot

After the guide, reboot, see if you still have the login loop issue. If you still have issues ,then look at /var/log/Xorg.0.log

/var/log/Xorg.0.log

Look for the error messages, which are indicated by (EE). In my case, it says

Failed to load /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so: libnvidia-tls.so.340.46: cannot open shared object file: No such file or directory

I do a locate libglx.so, it seems the file is sitting in another locations. It is time to rebuild xorg.conf

Rebuild xorg.conf

Have a look at this guide: https://lkubuntu.wordpress.com/2011/08/30/quick-and-easy-way-to-fix-x11-issues/

This was my last step and I was able to boot to the GUI.

  • I only had to purge the nvidia drivers to be able to reboot normally. – Fraser Jun 18 '15 at 8:18
  • Removing nvidia driver and rebooting the system, solve my problem. – d a i s y Sep 19 '16 at 6:33
6

I had exactly the same issue on Ubuntu 15.10. None of the solutions suggested here worked, nor did other tutorials. After several clean installs of the system I finally figure out what caused it.

DO NOT PUT nomodeset permanently in the boot parameters!

After a clean install I could not login without manually typing nomodeset in the grub boot options before booting. After the first login, however, I used to set it in the boot config file so that I won't have to type it every time. After one of the re-installs I forgot to do that and this time NVIDIA drivers installed without issue and I was able to login just fine.

  • Thanks for the tip! I NEVER would have figured such a thing out on my own. – Dustin French Mar 1 '16 at 20:25
  • I discovered it completely by accident because after one of the countless reinstalls of the system I just forgot to add it and everything worked like magic. – user3556519 Mar 1 '16 at 20:32
  • Where would I go to find/edit the boot parameters? – Neal Mar 3 '16 at 19:06
  • @Neal here's info askubuntu.com/questions/38780/… It describes how to put nomodeset in the boot paramters, which is sometimes needed for the initial runing of the system before installing the nvidia drivers. If it is there, you can remove it in the same way. – user3556519 Mar 4 '16 at 17:02
  • Thanks, I did nomodeset too while install 16.04 and after intallation, I installed the nvidia drivers. Post which I was not able to login, tried every solution on all the askubuntu questions. This should be mentioned as the final step in the articles/answers where they tell you to add nomodeset while installing! – Abhinav Upadhyay May 1 '16 at 16:22
2

I couldn't install the package

sudo apt-get install linux-kernel-generic

but this solved the problem with the login-loop for me:

sudo apt-get install linux-generic

thx for the idea with the kernel

1

IMHO Optimus is Evil.

Ubuntu 14.10 gifted me a few grey hairs because of Nvidia, then I switched to Win 8. Yesterday I felt like I'm missing something with Win 10 and downloaded 15.04. First run after install and black screen with continuous failure sound. Ctrl + Alt + F1 didnt display the console. Reinstalled 2 times before i remembered 14.10 problem with Optimus. Solved the problem only with Bumblebee.

1

I had a similar prob but a secondary account could log in so i knew my system wasn't borked. Here's how I fixed it. I went to the home folder of the offending account and trashed all the hidden config folders and files that pertained to gnome, gtk etc. or anything I didn't know I wanted to keep (like Browser settings, music, etc.). Reboot. I had to re-set some system preferences and rearrange desktop icons, but much preferable to a whole install with adding repositories and extra packages. Give it a go before blowing it away and fresh installing.

1

Slightly off-topic, but if you have AMD instead of nVidia: After updating 14.04 to 14.10 and then 15.04 I got caught in the login loop. After much poking around at problems with nVidia drivers, they were not much help. I have an HP Pavillion with AMD CPU & Drivers. Here were the simple steps that worked:

Press ctrl-alt-F1 to get a console prompt (non-gui).

dkms status # shows that fglrx-core was installed
sudo apt-get purge fglrx-core
sudo apt-get install fglrx-updates
dkms status
sudo reboot now

Then all was well.

  • Thank you, this exactly solved login issues after a kernel upgrade came down the wire. For those coming later, there may be a red herring error from VirtualBox ("vboxclient: the virtualbox kernel is not running. Exiting."), but the login issue was due to display drivers. – doublemarked Aug 20 '15 at 9:06
1

This link worked like a charm for me - https://www.benburwell.com/posts/getting-login-to-work-ubuntu-15.04-nvidia/.

It guided me to the logs where it shows the GLX module was failing to load, and instructed to reinstall the nvidia drivers.

I did one better by going to http://www.geforce.com/drivers and finding my latest linux 64-bit driver, and using the urls in there instead.

1

For me, I just forced a reconfig of the graphic server by deleting the .Xauthority file in a tty in the home folder:

sudo mv .Xauthority .Xauthority_old
0

I had done a clean install of 15.10 but found that lightdm login screen displayed incomplete words (pa rd) and also got in a loop when I logged in. Ctrl-Alt-F1 logged me in fine and I then issued a command sudo apt-get remove --purge nvidia-*. This listed a load of nvidia drivers and said none were installed. So I decided to install the latest as an experiment. sudo apt-get install nvidia-352 did the trick. After completion there were no incomplete words displayed at the lightdm login screen and I subsequently logged in with no problems. So my fix was to install an nvidia screen driver...preferably the latest. Cheers

  • i'm surprised that a clean install gave you similar problems. FIX THIS PLZ, CANONICAL!!! – Dustin French Mar 1 '16 at 20:24
0

Take a look at your /home partition with df command if it is not full. That can cause the reboot of x-server...

protected by Community Mar 15 '16 at 11:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.