From a new Ubuntu 15.04 install: When launching any application of the LibreOffice suite the LibreOffice splash screen starts with the following error box:

LibreOffice 4.4 - Fatal Error

The application cannot be started.

User installation could not be completed.

I have un-installed using:

sudo apt-get remove --purge libreoffice-core libreoffice-common
sudo apt-get autoremove --purge

and re-installed from ppa:

sudo add-apt-repository -y ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libreoffice

after a reboot I am still getting the same error. If I start from terminal ~$ libreoffice the same error boxes are displayed as stated above and the program hangs with no further output. if I start using ~$ gksu libreoffice the program starts without errors. If I click on a .odt document the same above errors apear and libreOffice does not start.

  • 1
    Start LibreOffice in a terminal and post the errors in your question. – A.B. Apr 25 '15 at 16:54
  • And why gksu? – A.B. Apr 25 '15 at 17:28
  • @EliahKagan Ah, sorry, I did not see that he has started LibreOffice once with gksu an once without. – A.B. Apr 25 '15 at 17:51
  • @EliahKagan Yes, running as guest starts LibreOffice without error. Renaming the libreoffice config folder and restarting solved the problem. No more errors. LibreOffice Suite now running as expected. Thanks to you and A.B. for the help. – Will Be Apr 25 '15 at 18:41
  • @WillBe Do you need your old LibreOffice settings, added words to the spell checker dictionary, and so forth? Although I wasn't thinking that getting rid of the old profile (actually, renaming it to move it out of the way) would be your ultimate solution, your recent comment seems to suggest that it fixes the problem for you. I'll post it as an answer, but if it's not an adequate solution by itself, please let me know. – Eliah Kagan Apr 25 '15 at 18:43

TL;DR: In ~/.config, rename libreoffice to libreoffice.old.

Often a bug or other problem that keeps a big, complicated application (like LibreOffice or Firefox) from starting correctly is triggered by something in the profile of the user who runs it, that is, in user-specific configuration files. When this happens, you can rename the folder that contains these files (or delete it), which effectively clears the profile and causes a new one to be automatically generated, usually without the problem.

Most graphical applications store their user-specific configuration data in a folder inside the .config folder which is itself in your home directory:

  1. Press Ctrl+H in Nautilus (this also works in most other file browsers) to show files and folders whose name start with ..
  2. Go into the .config folder in your home folder.
  3. Find the folder (inside .config) named libreoffice.
  4. Make sure LibreOffice is not running. In this specific case it appears to be exiting completely after giving you the error, so you don't have to do anything for this step.
  5. Rename this libreoffice folder to libreoffice.old.

Or if you prefer a console way:

  1. Open a Terminal (Ctrl+Alt+T).
  2. Make sure LibreOffice is not running.
  3. Rename the profile folder with the command:
    cd ~/.config && mv libreoffice libreoffice.old

It appears from your comments that moving the libreoffice user profile folder aside like this has worked for you. In cases where you don't still need to use any information from the old profile, this is a complete solution. (In other cases, this is a workaround or partial solution.)

If you don't need your old LibreOffice settings, words added to spell-checking dictionaries, or any other user-specific configuration data for LibreOffice, then this solution is all that you need.

More generally, this technique is especially likely to work when there is an indication that the problem is user-specific. In your case, troubleshooting revealed:

  • LibreOffice ran successfully when you logged in as a Guest.

  • LibreOffice ran successfully when launched with gksu, which ran it as root. While sometimes this succeeds by overcoming permissions problems (when it does, this should be considered a workaround rather than an ultimate solution except for utilities that do actually require root privileges), often this succeeds simply because it uses a different user account with a different profile.

    Unlike running it with straight sudo (which should not be done), gksu libreoffice, gksudo libreoffice, sudo -H libreoffice, or sudo -i libreoffice make libreoffice use the LibreOffice profile in the root user's home folder (/root), creating it if it doesn't already exist.

    Of course, you should not run LibreOffice to do actual work with it, as it is best to avoid running programs--especially large graphical programs that may contain security vulnerabilities due to their compexity--as the root user.

| improve this answer | |

If you have more time for trouble shooting and want to save as much of your personal stuff as you can, then instead of deleting the whole /home/*USERNAME*/.config/libreoffice folder, try to rename just the /home/*USERNAME*/.config/libreoffice/*VERSION#*/user/config/ folder. It worked for me, but I still have to test to see what all is now missing or different from how it was before the incident, and that happens over time when you discover stuff mid work flow.

You could even narrow it down by sub folder or even single (suspect) files within those. Pinpointing the problem better will help with bug reports, and may give others a better starting place for trouble shooting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.