8

system-config-samba does not open. It doesn't matter whether I install the program through either the command line or the software center. When I try to open the program it prompts me for my password and then closes. It does this every time and I can never get Samba to open.

I have installed it on 2 different computers with fresh installs of Xubuntu 14.10 and 15.04. The same problem occurs. I have tried to modify the smb.conf file manually but it doesn't work, and I've tried to copy over another's completed smb.conf file and still no luck.

Let me know if there is a way I can get my home network up and running.

  • Are you referring to system-config-samba? It's not clear exactly what you are talking about. – Elder Geek Apr 25 '15 at 16:39
  • Yes it's system-config-samba. It's the only GUI samba that's available in the software center. If there's another GUI front-end for samba then I'd be happy to try it. – Rockishi Apr 27 '15 at 18:46
  • Thanks for clearing that up. I've edited your question for clarity. – Elder Geek Apr 27 '15 at 21:30
8

In Ubuntu 15.04, system-config-samba fails unless you launch it with superuser privileges (gksu system-config-samba). I was subsequently able to launch system-config-samba from the Unity dash once I had logged out and logged back in after I configured samba for the first time using gksu.

I also got the following error message the first time:

SystemError: could not open configuration file `/etc/libuser.conf': No such file or directory

I resolved this by creating an empty text file 'libuser.conf' in /etc:

sudo touch /etc/libuser.conf
  • what does that empty file do? – endolith Jan 22 '16 at 0:53
2

system-config-samba has a confirmed bug here you may wish to subscribe to it (recommended). An alternative would be to try smb4k available in the software center. More alternative Samba GUI's are discussed here

  • 1
    reported 8 years ago and still not fixed – endolith Sep 28 '16 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.