2

This post worked perfect for 14.04 as well as 14.10. But for 15.04 there seems to be a strange issue. The application starts and gets a tunnel ip addresses but doesn't forward any traffic. The bytes sent stays at around 300 bytes and received is always 0. Any Idea how to solve this?

In case the application closes immediately after opening then make sure you have xterm installed.

1
  • If any of you is using Ubuntu 15.10 + you are better of using [Openconnect] . You can get the DSID from your cookies after login via browser. [Openconnect]: infradead.org/openconnect/juniper.html – Akilesh Apr 25 '16 at 7:37
3

Seems like the bug is reported at

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1444332

I've tried to downgrade to kernel 3.18 and it works (as a workaround).

Edit:

How to downgrade:

  • Find the kernel packages at http://kernel.ubuntu.com/~kernel-ppa/mainline/ (Here I choose v3.18-vivid).
  • For 64-bits system, download linux-headers-3.18.0-*-generic_*_amd64.deb linux-image-3.18.0-*-generic_*_amd64.deb linux-headers-3.18.0-*_all.deb (For 32-bits, download the ones end with _i386 instead)
  • Install the kernel with sudo dpkg -i linux-headers-3.18.0-*.deb linux-image-3.18.0-*.deb
  • Then, you're able to choose the kernel at grub when rebooting (from the advance options).
  • To set kernel 3.18 as default, you may check Set "older" kernel as default grub entry, which I haven't try yet.

Source: http://ubuntuhandbook.org/index.php/2014/12/install-linux-kernel-3-18-ubuntu/

2
  • Please also specify how to downgraded. I am unable to find the 3.18 package. – Akilesh Apr 26 '15 at 7:55
  • I didn't really downgrade it as a default kernel, but added an option for 3.18 when I want the VPN feature to work. Have edited the answer. – pishen Apr 26 '15 at 8:40
2

Found it. Looks like this is a Kernel bug in 3.19 kernel which is already identified and fixed.

https://bugzilla.kernel.org/show_bug.cgi?id=90901

Hope Ubuntu pushes out the 3.19.2. (or downgrade to 3.16)

2
  • 1
    They would not downgrade. We either have to wait for an upgrade or downgrade it manually as pishen suggested. – Akilesh Apr 26 '15 at 5:11
  • 1
    i tried to upgrade to 3.19.2 and it still suffers with the issue. But latest 3.19.8 works fine and fixes Juniper VPN. – farincz May 13 '15 at 8:30
0

No need to install an older kernel version. In my case, I already had an "older kernel" entry in my grub menu (3.16.0-34-generic). Just enter into the advanced menu in grub and select the older version.

2
  • I installed it fresh and did not have any older kernel. But I did download 3.16 and when using I would that the system got too slow. Almost unusable. Did you face anything like that? – Akilesh Apr 27 '15 at 3:59
  • In my case I upgraded from 14.10 to 15.04 (hence the 3.16 kernel) and no, there's no slow down at all (didn't feel any difference actually). I'm on Ubuntu GNOME. – Sir_FZ Apr 27 '15 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.